+1
Discuss

Amazon Fire & Fully discussion

Terry (ActionTiles) (Co-Founder) 2 years ago in Browsers Tablets Phones / Amazon Fire updated by afgoody 2 weeks ago 219

Just posting this link here for now for reference:


https://www.facebook.com/groups/SmartThingsUsersGroup/permalink/999756380167437/


I need to use AT for pet sitters to be able to interact with ST when staying at my house. I don't want them to have access to my iPad because all of my Apple devices all linked nor do I want to share the ST app with them, so I bought the 3 pack 8" Fire tablets during Prime deals which will be dedicated to AT/ST. Last night, I was able to install Fully Kiosk Browser and set it up to turn on w motion. The only problem I can't seem to fix is that it still turns on to the lock screen. I am hoping someone can give me some settings to fix this. These tablets are Fire HD 8 (7th Generation) so I am hoping this was not just a feature in previous versions.

Readers are encouraged to browse Fully's website, as it contains a direct link to the APK and descriptions of all the features.

Fire

Answers

+5
PINNED

Hello,


I'm developer of the Fully Kiosk Browser. I got the Fire HD 8 (6th Generation) with Fire OS 5.6.1.0 for testing and in the last days I could make some important improvements in Fully Kiosk Browser for Fire Tablets.


Many previously disabled options (like Advanced Kiosk Protection, App Whitelist, Single App Kiosk) relying on the Usage Access permission are working now. You will be asked for that permission if some of those options are enabled.


The Kiosk Mode is now working without additional apps like Launcher Hijack. Uninstall those apps! When enabling Kiosk Mode in Fully please read the dialog box text carefully and enable the Detect Home Button option in Fire OS Accessibility Settings. This is required to make the Kiosk Protection with Fire OS. (Note: This accessibility option is sometimes reset by Fire OS - no idea why, you will get a warning toast when Starting Fully Kiosk in this case. If the Advanced Kiosk Protection is enabled, your device is probably still 99% protected in that case.)


Due to the changes in accessibility service the Fire OS edition of Fully Kiosk Browser there will always be a special APK file to install. It won't be accessible on Google Play as Google doesn't like apps tampering with accessibility service. May be I will make the app available in Amazon store if anything works alright.


https://www.ozerov.de/fully-kiosk-browser/files/2018/05/Fully-Kiosk-Browser-v1.25-beta-6-fire.apk


The main Fire OS specific issues remaining:


1. The Lock Screen absolutely can't be disabled without root. Also the short Power Button press will always lead to the lock screen. All this is no issue with normal Android.


2. The Webview can't be updated separately, but it seems to be updated with Fire OS and is slightly outdated (version 59 vs. current ver. 66) with Fire OS I tested.


Again, all these new features seem to work ok with Fire OS 5.6.0.1. With older Fire OS versions there can be things broken. If you find some issues with this beta version please feel free to report to info@fully-kiosk.com and let's see what we can do.


Alexey


+4
PINNED

Fully's feature to turn on when motion is detected is the perfect compliment to a wall mounted tablet displaying actiontiles.  The problem is, if you're running an Amazon Fire device, the device wakes to the Fire lockscreen.  As there is no root for the latest FireOS (5.3.3.0+), I thought I would just have to live with it.


Turns out there is an option in Fully to turn on a black screensaver (Dim:).  This keeps the device awake (so it uses more battery), but keeps the Fire lockscreen from activating.  The net effect is when you walk up to the tablet (or the tablet detects motion) ActionTiles appears.  Very Cool.


This is probably more practical for those running a power source to their wall mount. I'm not at the moment.  Pretty sure my tablet will be dead by the end of the day if it never goes to sleep. Anyone else figure out a more elegant work-around?

+1
PINNED

Starting some version of Fully Kiosk there is no option Screensaver URL in Device Management settings any more. Please set the Screensaver Brightness option in Screensaver settings to 0 in order to make the screen dimming to the possible minimum. Don't forget to set the Screensaver Timer.

PINNED

Found it! 😊


In Fully under "Device Management", set Screensaver URL (PLUS) to "dim:" (no quotes). Works great!

PINNED

Hello,

I'm developer of Fully Kiosk Browser. If Fully Kiosk crashes sometimes we recommend re-install Fully and run a simple website like www.google.com for a couple of days. If Fully Kiosk doesn't crash then the issue is probably the complexity and behavior of the website which leads to crashes in Android Webview. Unfortunately we can't  catch, analyse or fix anything in Android Webview. It's completely out of our control. The problem is even worse on Fire OS as a slightly outdated version of Android Webview is installed and can't be updated separately. 


Silk Browser doesn't use Android Webview according to these FAQs, so the results in Silk can be different.

https://developer.amazon.com/docs/fire-tablets/web-hybrid-app-faq.html

Another common source of non-reproducible crashes is the device overheating when visual motion detection is used. Try disabling motion detection. The tablet devices and cameras are usually not designed for running 24/7 at all. Please try running Fully Kiosk on another device type using Android OS (not Fire OS).

Alexey

Do you have to remove the ads form the firetablet for this all to work? or can i buy the cheaper one with the ad's I plan to leave it plugged in 100% of the time


TIA

An update and maybe my mistake the reference to dim seems to be the answer. I think this forum has got rather unweildy. Maybe someone could put a summary at the top.

Are you saying you updated your fire and it broke it? I'm curious as I was thinking of buying a fire for just this purpose

+2

No nothing like that. I paid for removing ads. I bought the full version of open kiosk and Smarttiles, however still couldn't get what I wanted which was a simple kiosk based ST system. I do think the dim function may have resolved that, I'm not enough hours in but so far it's working , my screen has gone into lock mode so all positive. Having said all that it would have been so much easier with a cheap basic android tablet, hence my comments.

+1

That should have said that "so far my screen has NOT gone into lock mode" which would have been excellent. Unfortunately this morning it was in lock mode again. Although its only a swipe once a day to get rid of it - it is a pain that you cant get around that.

I really don't know why your system keeps ending up in lock mode. I don't have that issue. I have the screen saver set to dim: & went into developer mode to set the screen to always be on. I have the fire with the adverts and they never appear.

Sounds like maybe getting a non Amazon tablet is the best plan then anyone have suggestions? Would prefer to stay under 100.00 maybe an insignia or Lenovo?

Buy the cheapest or secondhand. It requires real basic processor power.

+1

I think the problem with the screen constantly locking is down to the fact its looged into Google Store. Is there a way to logout?

with the new Fully browser update I can’t get “dim:” to work anymore.  Anyone else?

+2

The default is "fully://color#000000"


That works for me

+5
PINNED

Hello,


I'm developer of the Fully Kiosk Browser. I got the Fire HD 8 (6th Generation) with Fire OS 5.6.1.0 for testing and in the last days I could make some important improvements in Fully Kiosk Browser for Fire Tablets.


Many previously disabled options (like Advanced Kiosk Protection, App Whitelist, Single App Kiosk) relying on the Usage Access permission are working now. You will be asked for that permission if some of those options are enabled.


The Kiosk Mode is now working without additional apps like Launcher Hijack. Uninstall those apps! When enabling Kiosk Mode in Fully please read the dialog box text carefully and enable the Detect Home Button option in Fire OS Accessibility Settings. This is required to make the Kiosk Protection with Fire OS. (Note: This accessibility option is sometimes reset by Fire OS - no idea why, you will get a warning toast when Starting Fully Kiosk in this case. If the Advanced Kiosk Protection is enabled, your device is probably still 99% protected in that case.)


Due to the changes in accessibility service the Fire OS edition of Fully Kiosk Browser there will always be a special APK file to install. It won't be accessible on Google Play as Google doesn't like apps tampering with accessibility service. May be I will make the app available in Amazon store if anything works alright.


https://www.ozerov.de/fully-kiosk-browser/files/2018/05/Fully-Kiosk-Browser-v1.25-beta-6-fire.apk


The main Fire OS specific issues remaining:


1. The Lock Screen absolutely can't be disabled without root. Also the short Power Button press will always lead to the lock screen. All this is no issue with normal Android.


2. The Webview can't be updated separately, but it seems to be updated with Fire OS and is slightly outdated (version 59 vs. current ver. 66) with Fire OS I tested.


Again, all these new features seem to work ok with Fire OS 5.6.0.1. With older Fire OS versions there can be things broken. If you find some issues with this beta version please feel free to report to info@fully-kiosk.com and let's see what we can do.


Alexey


Hi Alexey,


I have a question about the procedure on how to setup Fully Kiosk (FK) for the Fire HD 7 (FHD). I just got a FHD Tablet that was running the stock FW of 5.4.0.0, and i used this script from Aron7676 in the ST community forum to get my FHD up and going with FK and removing all the bloatware. Before I continue with my question, let me explain the purpose of my FHD:


- I am wanting to have FHD setup as a controller not mounted on a wall (yet)

- I want to have the FHD locked down into only FK with AT (actiontiles), with the exception of allowing certain AT to open up certain apps (Sonos, Harmony, ST (smartthings), and Alexa).

- I know that on the Fire OS the lock screen can't be overrided, but this is not a concern of mine as i know the alternative is to have the screen always on with dim and something like DAKboard installed which all of this means power consumption will sky rocket and since i don't want to have this tablet docked so i don't want it to be always on


Here is what i have so far been able to achieve:

- I have been able to lock down my FHD with FK.

- I have AT as my default URL

- I only have to swipe up to open the device and that is it


Here are the questions/concerns i have:


-  While i am able to lock down my FHD with FK, i get this error message so far. IMG_1315.jpg IMG_1317.jpg ( I believe that this could be an issue coming from the fact that i have Launcher Hijack V3 installed (?)

- Given the script i used to setup my FHD I am concerned if i have setup this correctly. 

- How can i have FK be in Kiosk mode (locked down) but still permit certain apps to open up. Any suggestion on how to do this?

- Right now FK doesnt open up directly into Kiosk mode it only opens up but it doesn't have it locked up. This is not a big deal to me as I don't plan on turning off the tablet unless i won't be using it for a couple of days


Any help would be greatly appreciate it


thanks


Miguel

+1

Please use the latest version of the Fully Kiosk 1.25 (fire edition) from this link:


https://www.ozerov.de/fully-kiosk-browser/files/2018/06/Fully-Kiosk-Browser-v1.25-fire.apk


Uninstall the Launcher Hijack App.

Miguel mentions "- I only have to swipe up to open the device and that is it"

I have been banging on about this point.

Is it generally accepted that swiping up (which I consider is locked), is the only way of opening. AS I have previously mentioned my Fire device goes into locked more at some point overnight then remains unlocked for the rest of the day. I have it set to dim which in normal circumstances works fine.

Thanks

+1

The Lock Screen absolutely can't be disabled without root. Also the short Power Button press (or other reasons?) will always lead to the lock screen. All this is no issue with normal Android, where Fully Kiosk can skip the lock screen programmatically.

That's great appreciate the response, Alexey O.

Anyone here have issues with using Dakboard in Fully where the screen goes to white and/or black for a good 20 seconds before Dakboard renders?

+1

Unless it's just me, I think DAKboard is having something SSL issues. I changed the URL to http, and it rendered fine.

You're correct. The SSL port of Dakboard.com is down. Not uncommon to happen for short temporary outages; hopefully they are aware of it.

I'm trying to buy a license for Fully, but my screen keeps flashing (bright to dim) and keyboard disappears on every flash. This is happening when I try to enter my payment info. Is this Fully browser causing this?

It may be a quirk of the tablet (try your tablet in Portrait tall mode instead of Landscape?), or Fully itself.


You can use this link, however, to purchase your License from a different device and/or browser:  https://www.ozerov.de/fully-kiosk-browser/#license

+1

Never heard about something like this. Have you changed any settings in Fully Kiosk? Please send me a video demonstrating this issue to info@fully-kiosk.com 

Sounds like it could be the tablet (although it's brand new and only does it when I launch Fully browser). It was working fine last night when I first installed it. But then I was looking through some settings in Fully and messing with them. It sounds like I did something, but sounds like this behavior is unexpected regardless of what I did.


My tablet (Fire HD 7) was on 5.4.0 I believe. It should still work, right?


I've read through all the posts and looks like most are installing google apps? Why do I need to do that? I just want to run AT with Fully to put a tablet on my wall for smart home controls.

You can reset all Fully Kiosk settings by uninstalling the app and installing again. If the issue occurs again please send me a video demonstrating and your exported fully-settings.json file to info@fully-kiosk.com

I’ve been using Fully, AT and TinyCam Pro on a Fire HD 8 for months now with zero issues. In the last couple of weeks a problem occurs daily which requires me to restart Fully. Basically the tiles are displayed but the contents in the things tiles are blank. Media tiles are still visible OK. Also the screensaver defaults back to special offers. Once I restart the Fully app all works fine until the next time. 


I’ve made no config changes to the Fire tablet except I would guess any OS updates. It’s currently running 5.6.1.0. 


Any ideas?

There's a lot of moving parts; updates to any of them could suddenly introduce a problem:

  • ActionTiles web-app; updated a few weeks ago, but we have not had major issues reported.
  • Fully; updated a few days ago.
  • Fire OS update ... not sure when the last one was.
  • tinyCam...

The key is to patiently attempt to isolate the issue by first running a simpler Panel, particularly without Media Tiles, and not running background processes like tinyCam for a little while.


If possible, you can try an older version of Fully - Contact Fully support to see if they recommend this type of diagnostic approach. But you can isolate easier, by just temporarily using Chrome or Firefox or Silk or Opera...

So after several days of testing I had to remove the media tiles that fed from TinyCam. Even without TC running on the tablet these tiles seemed to cause the issue. I've been able to keep all other media tiles without any issue. Any idea why? Possibly a Fully issue and not AT related. It's a shame as TC was feeding some streams from my Wyze cams.

If something like this isn't working in the web rendering the issue is mostly caused by an incompatibility of the Android Webview and the website. With Fire OS you unfortunately can't install another Webview version than one provided by the current Fire OS version.

Just wanted to provide some additional information.  I'm also running  Fully, AT and TinyCam Pro on a Fire HD 8, and I am noticing the same behavior suddenly too.  Tiles are appearing, but with no content.  Media tiles are good though.  

I recently made a Fully setting change to NOT keep the screen on, and that's when I first noticed the issue.  With "Settings-Device Management-Keep Screen On" ENABLED, I do not see the issue.  With that setting disabled, the screen turns off, so you have to unlock the lockscreen when you turn the screen back on.  Once you get past the lockscreen, the AT panel is there, but with no content in the tiles.  I cannot say for sure that this setting is the root cause, but it seems to be related, at least for me.

Fully version - 1.25-fire

TinyCam version - 10.0

Fire OS - 5.3.0 (updates turned off intentionally.  Version hasn't changed since March when I bought tablet)


UPDATE: After some more testing... with "Settings-Web Auto Reload-Auto Reload on Screen On" ENABLED, the problem goes away.  It does take a second for your AT panel to load, but it loads correctly.  If you do not have your screen ever turn off, then you could try "Settings-Web Auto Reload-Auto Reload on Screensaver Stop".

I upgraded to 5.4.1 and uninstalled Fully. And I downloaded google play apk which allowed me to download/install the Fully Kiosk from the play store. It is now behaving normally. What else is the reason for installing google play for this application? Are there other apps I need? It looks like Fully keeps the screen on 24/7 currently, will that drain my 12V battery from my alarm panel too quickly? It looks like most are having a screen saver running to prevent this?


Thanks

+1

I'm using Fully 1.25, Dakboard, and ActionTiles.  On my ActionTiles I have some of my doors represented and I user LANnouncer to chime when a door is opened.  If Fully is currently on screen saver mode, then I don't see which door opened unless I touch the screen.


Is there a way to configure Fully so that if the ActionTiles screen changes that it causes it to come out of the screensaver?

+1

Technically, ... maybe.  We hesitate to put in too many "Fully specific" functions, because that leaves out all the iPad users, etc.... But we're thinking about it.

OK, I'll keep my eye out on future releases then.  Thanks.

Using a fire 7, fully, and AT. Every night at 12:30:00 exactly, it goes to the lock screen. It used to do it once a week or so, but now its every night. I dont see anything obvious in any settings. Thoughts?

Several people have reported this nightly lock screen issue ... but not a lot; so I don't think everyone experiences it ... I wonder what's going on.


What timezone are you in, Jeremy? I finally confirmed that mine does this at 4:00am everyday. I should test changing my Fire Tablet timezone and see if that changes what time it happens and perhaps can force it to be happen for testing purposes.

i am in EST, which i believe is GMT -5

Jeremy,


Do you have an "Alarm" indicator in your Status Bar? Mine always shows 04:00 (am) of the next day, so that is obviously not a coincidence. But I absolutely cannot determine what the source or purpose of the alarm is. Maybe some side-effect of Google Play Store installation.

in the top right there is what looks to be an alarm clock, but i just checked and there are no alarms configured

Swipe down from the top edge of the screen and the status bar will expand.


The time of that "alarm" will be shown - I'm betting yours shows 12:30 am, of course!


Tapping it should show you or bring you to the source App for the Alarm - but mine goes nowhere.

it does show an alarm at 1230, and when i click it does nothing. When i look under alarms, there are none configured

Thanks for confirming that, Jeremy...

So the problem really is outside the scope of ActionTiles & Fully. I've done a little Googling but found no result that was helpful.


I have spawned a new Topic for this, as it is not related to Fully... Here's the new Topic link:

This may actually be Fully related.  I have no alarms configured on my tablet, but I have the icon at the top too.  This is because in the Fully settings, you can enable "sleep and wake" times.  This automatically turns the screen off to "sleep" and turns it back on to "wake".  When it wakes, it goes to the default lock screen until you unlock it.  It's in Fully-Settings-Power Settings-Schedule Wakeup and Sleep (PLUS).


Side note: I have mine setup to sleep every night to help avoid burn-in and/or premature screen failure.  If you do want to use this feature, you must use 24h time format (HH:MM).

Yes, if you use the Scheduled Sleep/Wakeup Fully Kiosk will lock the device when hibernating the device. There is no way to make the device sleep on Android without locking the device.

Thanks for the confirmation, Alexey!


I don't recall ever putting in a Scheduled Sleep time (of 04:00h) - could there have been a default value? Regardless, it was easy enough to clear out the entry. This was a nice discovery today.

+1

No, there are no defaults in the Sleep/Wakeup Schedule.

Has anyone been able to use Alexa Hands Free from the Fire Tablet and then successfully been able to return to Kiosk mode after Alexa's response?

I wonder what the official Fire / Alexa behavior is supposed be when given a voice command that triggers a visual, but... Whatever.


First, let's make sure we are not talking about "Show Mode". ActionTiles cannot be concurrently used with Show Mode (maybe someday).


Here's my observations:

  • When I give a smart home command (turn on lamp) the screen remains in ActionTiles.
  • When I ask for a definition or shopping list, pressing either X or Back returns to the ActionTiles Panel - no problem at all.

What would you expect to be different??

For nomenclature, you're right to ascertain that we're not talking about "Show Mode".


Asking for a more direct request (Example: "Alexa, can you hear me?") results in a screen visual summarizing the question. Which stays on screen, and one must click the X hotspot in top right corner to exit the Alexa screen.


I am just wondering if there is a "time out" of some kind that doesn't force me to touch the screen in order to get back to Action Tiles and would close the Alexa screen automatically.

As far as I am aware, there is no timeout option built into the Alexa integration to automatically return the screen to the previously running App. 


You may find further assistance / workarounds on this from Amazon Customer Support and/or various peer support groups you might find via internet search.

+1

I've just been looking at this today and found a workaround. I now use Automateit to run fully if its been deactivated for 10 minutes. Works great with other apps that link from Actiontiles to such as harmony, sonos etc.

Paul, can you tell me if this is still working? I'm trying to get setup with FireHD 10 tablets using Fully Kiosk, Dakboard, and actiontiles. The issue for me is that when someone does an alexa announcement, the screen takes over to show that via alexa (which I want to keep), but automateit is not working and I believe due to the fact that there are no "app usage settings" available to allow it. It does not show in the security settings like fully does.

+1

Alexa works on my AT Panel with Fully on a Fire8 without leaving the AT page. The blue Alexa bar at the bottom lights up and that is it. 


+1

It is the same for me. I use a screen saver of a picture of us in my bedroom. When I swipe I get the AT screen. When Alexa is awake a blue line appears underneath.

i can only get Alexa to work if kiosk is not in lockdown. 


I have played eeih whitelist but fully kills the app still. I think another service is running that fully is blocking. Havent worked out what it is yet. 

try disabling the option to disable the power button.  For some reason Alexa works in fully when I do that.  The option is under kiosk mode.

I’m very new to this and a novice, so bear with me. 


Fire 8. Fully browser. If I try to launch anything from Fully (link from AT, app from Universal launcher, even Dakboard screensaver)


If Dakboard I get this message 

Webpage not Available

The webpage at “whatever I’m trying to launch” could not be loaded because


Net::ERR_TIMED_OUT


If Universal Launcher or an app from an AT link I get


Webpage not Available

The webpage at “whatever I’m trying to launch” could not be loaded because


Net::ERR_UNKOWN_URL_SCHEME






Thank you in advance for any suggestions. 

@Zach are you using the plus version of Kiosk or the free version?

Guys, ive been picking up something with fully over the last month and I thought I would see if anyone else is experiencing the same.

I use the motion detection feature to dim the screen and reactivate on motion, but ive been finding that a lot of the time, fully DOESNT bring up the brightness again and Ill have to manually turn it up by pulling down the menu and adjusting the screen brightness. It then works fine for the next day or 2 and then the same issue again.

Has anyone found the route cause of this, or is it something that you just have to put up with?

I experience this ... but very rarely.


I recommend contacting Fully Support... they're very helpful!

Hi, I also heard of such brightness issues with Fire OS. If you on the latest version 1.26-fire I don't have any idea what's going wrong. It's almost impossible to fix something irreproducible.

Thanks Alexey, it seems to be something to do with the camera. Today I landed up getting an error about the camera not responding. Restarted the fire and all is good in the world

+1

Running Fully (PLUS) on FireHD but noticed an issue with the battery. Effectively the device drains itself down to 0% when running Fully even when plugged in resulting in no charge. Also never appears to charge higher than 50-60%. If you exit Fully the device does not exhibit any of this behavior, and will charged back to 100% as expected over time with no battery drain. Not using any of the power management features in Fully. 


It's as if the app stops the battery charging.....super weird.


Running FireOS 5.6.2.0 / Fully v1.26 (355) / Webview v 59.0.3071.125


Anyone else seen this? 

I had the same issue when I had a gif running on the screen. I switched to another page without a gif and it stopped draining the battery.

Interesting, was it something like a weather forecast gif as a tile? I have one of those pulled from the local TV network. I'll try removing it and see what that does.

+1

That's exactly what it was... I keep it on an inactive page to look at when I need it, but always go back when I'm done.

+1

I setup a Fire8 with Fully and AT a couple months ago. 

My battery stays at 100 percent. 

The Fire8 is powered from the old alam system which is 12 volt and I installed this step down transformer in the wall behind the tablet: https://www.amazon.com/gp/product/B00NME2PWC/ref=oh_aui_detailpage_o08_s00?ie=UTF8&psc=1

I have one of my outdoor cameras on the panel, a gif for local weather, and a couple of other images that update. 

It uses very little data.

Make sure to check the frequency of update setting for media in AT.

I had it set to update every five seconds during testing.

I believe I changed it to every 15 minutes before I installed it. 


I hope you find the above helpful.

Thanks,

Luke

+1

Thanks for sharing your success experience, Luke!


I also run a Fire HD8, always on, dimmed using Fully. I have a live video Tile and just added a weather radar GIF. No power drainage issues (I don't think my USB supply is particularly strong).


Most GIF do not need frequent updates.


Definitely suggest checking all the system settings in case there are any obvious ones that could impact power usage. I'll spin up an HD7 with stock USB power and report if any issues. HD7 hardware is less optimal than HD8, though we haven't heard if power drain being a prevalent problem.


...Terry.

I disabled 1 x GIF and changed the other to refresh every 10 minutes with no impact, same battery drainage issue. Am going to disable the other GIF and see if that changes anything today. 

+1

OK great tip, I had a tile running to update every 10 seconds, have adjusted that to 10 minutes, will see if that has an impact.

Did you manage to resolve this?

I have a screensaver which loads dakboard and in the background it loads one of my webcams every 10 seconds, after another 2-3 weeks it drains the battery.

I recently added a second screen saver (so it toggles between the above one and) which loads my tesla powerwall which shows a live view of solar / battery / grid status, now my battery tends to drop to 16% daily.

I have my display on 180 and when in screen saver the brightness is 140.

I'm playing with the API to try disable to screen to brightness 1 between 1am and 5am so it will charge automatically daily.

This on both an old 7 fire and a new 7 fire and I just bought an 8 fire and does the same

im running action tiles on my fire hd8 tablet with fully kiosk. I just noticed that on my main dashboard I created it doesnt cometly fill entire screen on bottom. I have a black bar at bottom of tablet that only hides the status of the bottom row tiles . Is this an issue with Fully kiosk or action tiles ? I haven't changed anything....

Angelo


The last update to ActionTiles was a few days week ago. When did this problem start for you?

Can you attach a screen shot please?

I have not noticed any problem on my Fire HD8 with Fully.

If I understand correctly, there is no way to disable going to the lock screen on the Fire?

The Fire lock screen can only be avoided  by activating "Always stay on when powered" option in the tablet Developer Settings. The lock screen will the only appear if you unplug the power or use the power button to turn off the screen.

Unfortunately, even with special offers (ads) disabled the lock screen cannot be fully disabled. Instead most people just use fully with a timed screen dim or screensaver and leave the power on all the time. 

Fully Kiosk's Fire OS FAQ says it works fine with Fire OS 6.2.1.0 (Oct 2017)

https://www.fully-kiosk.com/#faq-fire

Has anyone updated to the newest Fire OS version 6.2.1.3 (May 2018) and ran into any issues with Fully Kiosk (using ActionTiles of course)?

I asked Fully is there were any issues with the newest Fire OS and they said they said they had no idea and to ask here.

Thanks,

+2

I'm using it with the latest 6.2.1.3 ver. (Device got updated last week) for a week now with no observed issues - I'm running on the device action tiles in Fully and using Fully built-in screensaver and motion detection features

Brand new Fire HD 10 here running Fully via Google Play install work around.

Im getting somewhat frequent crashes and camera loading  failures. The charging port (and maybe battery?) seem to be pretty close to the camera, so not sure if they're causing the camera to overheat a little because that area gets pretty warm. 
Anyone else run in to this? Trying to figure out how I can dissipate the heat a bit better having it mounted on the wall without it sticking out too much further. Maybe a thermal pad to help pull some of the heat away from that localized area. 

Thanks for the info on this thread as its been really helpful.

I've now setup my Fire to dim the screen and wake upon motion. However beforehand I had the fire set to Auto brightness but when it wakes it returns back to full brightness, which in the evening is too much and causes a distraction in the lounge. Is there a way with this setup to return from the dimmed screen to auto-brightness upon motion?

What happens when you set Device Management / Screen Brightness to "empty" ... i.e., system default.


Doesn't it return to the FireOS Setting of "Adaptive Brightness"?

Unfortunately not that I can see. I'm not sure what/why else is causing it to revert to full brightness.

Got a question that I'm unsure where to post so I figured perhaps there will be some insight here... 


I set up a brand new Fire 8, Amazon Drop-in was working no problem. Once I installed Google Play store and Fully Kiosk for AT, Amazon Drop-in no longer works. The Amazon communications settings still show that Drop-in is enabled, however if I try to Drop-in to this device, the Amazon Alexa app just tells me that it's unavailable. Also, I can't get this Fire 8 to Drop-in on any other Echo in my house. 

Anyone have thoughts? Is Fully Kiosk somehow suppressing this functionality?

Thanks in advance!

-jerm!

Try a couple things, Jeremy, please:


  1. Be sure that Fully - Settings - Other - Run as Priority App = off. (Not saying this is the cause, but it is easy to try). Exit Fully, reboot, and try drop-in again.
  2. Uninstall Fully and test drop-in again.
  3. Do you have any other hacks on the Tablet (e.g., Play Store?).
I didn't think Drop In was available on the Fires?  I have all new versions and if true that's great

Thats the thing... They did add Drop in starting in the beginning of December, and thats when I first set up this particular HD8. 


https://www.digitaltrends.com/mobile/how-to-use-drop-in-announcements-amazon-fire-hd/


It worked perfectly for about 2 days, and I used it with my wife connecting to the Alexa iPhone app for video calls. Then it suddenly stopped working. The end result of my lengthy call to Amazon support makes me believe what I've suspected, they rolled it out, then took it away. The last "Alexa Support" specialist I spoke with said it will come back in the next firmware update. (Based on the lack of factual knowledge by that support team, I won't hold my breath. 

Hi Terry,

I've checked on item #1, Priority is and was off. I've uninstalled Fully and rebooted, still no Drop-in.

I do have Google Play Store installed. I suppose my next step is to uninstall that and see...

Thanks for the quick reply, I'll check back.

Well... just a little update, went as far as to do a full factory reset of this Fire HD 8 (7th gen). The Drop in feature is still not working. At this point I can confirm it has nothing to do with Fully, AT, Google Play, etc... 

I've now been on the phone with Amazon support for over 90 minutes, and been passed around to 4 support agents... 2 of them don't even know what the Drop in feature is and all 4 have no clue what is going on. Its comical. Some of the worst support I've ever experienced (what do you want for a $50 tablet...?)  


My best guess as of now is that while Amazon recently rolled this feature out to the newer gen Fire HD's, perhaps they have disabled it for one reason or another, and just not informed any of their support staff. I'm about to call it quits with this support call and go get the tablet set back up for Fully so I can get it back on the wall and go to bed.

Probably a dumb question but I can't figure this out.  I have AT and Fully on a Fire Tablet.  I have Fully set to turn off after 90 seconds, and also have Motion Detection turned on.  Problem is when Fully turns off, the Fire goes to a locked screen, when Motion detects me, I am at the Fire locked screen.  I tried going to Settings = Display = only options there are time intervals, there is no option to not lock screen.  I know its there, how do I fix?  Thanks!
  1. FireOS settings.
  2. Device Settings.
  3. Tap the Serial Number 7 times. That will activate the Developer Options menu.
  4. In Developer options, toggle-on "Stay Awake" - Never sleep when charging.
  5. Leave the tablet always plugged-in.

I did that but the screen keeps locking?  Never sleep when charging toggle is engaged but when I leave room and return the screen is locked

Then one of your settings is incorrect.


What I've described works for everyone. Please change your Fully settings. You cannot have Fully "turn off after 90 seconds" ... that defeats the whole purpose of "Never sleep when charging":  "turn off" = "sleep".


+1

I've seen this happen when my battery was low. The tablet would tun off, charge a little but then automatically turn back on to the lock screen. My screen was too bright and I had live cameras and a low power USB adapter which led to draining faster than it could charge. Lowering the brightness fixed this for me.

Is it okay to leave the Fire Tablet always plugged in with a bright screen?  I have Fully and DAKboard running.

Not likely a problem... 


It might shorten the life of the Tablet a little bit, but considering the low price, it shouldn't be a significant worry if you have to replace it sooner than expected.


Take care if the power supply seems to be running hot. Always a chance of fire risk; so you just might need a higher quality one.

I leave mine on all of the time. I do not have dakboard. I have only had it up and running for about one month. I am concerned about screen burn in. But none yet.

I recently upgraded my old cameras to 5MP, and not sure this is related, but I get an error from the Fire Tablet with Fully Browser when going to my Actiontiles panel. It says “App Stopped Working”.  Anyone know why this might be happening?

High resolution cameras may not be a good idea embedded on a Panel. You might find parameters that can be added to the URL to request lower resolution and/or lower frame rates. You see, the MJPEG streaming format is extremely inefficient.

How many camera feeds do you have on one Panel?

Be sure to test for a while using a Panel with no Media Tiles, as that will help indicate if the cameras are actually the problem or if you have some other sort of browser or OS corruption.

So I even tested Full with Google.com as the home page and it still says "App Stopped Working" at all times.  Nothing to do with Actiontiles I believe.  Weird thing is that this error only shows on my Fire HD 10, but not on the Fire HD 7.  Both are on the same version of Fully, so not sure what the issue is!

Ummm... Several people have reported this, but I really don't recall if anyone has reported a solution.

  1. Uninstall and re-install Fully.
  2. Contact Fully Support but do NOT mention ActionTiles! (they will just try to throw the ticket back at us). Instead; find some other website to test with (Google.com is great).

I have AT setup perfectly with Fully Kiosk, utilizing Dakboard as the screensaver. It's set to stay on 24/7, and it does for the most part, but every day, early in the wee hours something happens which sends it to the lock screen. I've no idea what's causing this to happen. It's not a deal breaker, just curious what could be causing it. At first I thought it was the system update because the first time it happened it downloaded an update around 5am (but did not install it automatically I may add). This morning I found it at the lock screen again and when I checked the system update I can see it performed a check around the same time but did not find a new update to download, however could this be what's causing it? Is there anyway to check a log file on this device? Has anyone else encountered this before?

Lough72,

The most common reason we've seen for this is if you have a Schedule enabled on the tablet (usually, but perhaps not always, indicated by an alarm clock icon in the status bar).


Check Fully Settings - Power Settings - "Scheduled Wakeup and Sleep (PLUS)" and disable any schedules. Or you might have other Fully or other App(s) settings which set a recurring 24 hour scheduled event.

+1

That was it! Fully Kiosk was set to go to sleep at 1:30am and wake up at 6:30am. Either I set it up in the past or Fully Kiosk comes out of the box with that schedule. Of course, I looked everywhere except there.

Thanks the tip!

I have the same issue. Every night at 1230 it goes to lock screen. It does show an alarm clock at the top, but nothing listed in alarms or schedules

In every case we have heard, the culprit was Fully powered Schedule.

Uninstall Fully and try again, or soft/hard reset the entire Tablet to factory.

Now that it's been available for some time; are most people using the fire os APK when installing fully?  Or sideloading the standard Android version?  I've just setup a Fire 10 with fully and actiontiles.  The pin entry and some other functions are really laggy for me in the fully browser.  However, if I open AT in the silk browser everything is way more responsive.  Does the sideloaded Android version run any smoother?  Any suggestions from anyone?  The only media tile I have is a weather radar gif being updated every 15 minutes.

How slow is "laggy"? I just tested using FireOS APK of Fully on Fire HD8, on a Panel with 2 active streaming media tiles. 6 number PIN entry was no slower than I could reasonably type it (i.e., tap, tap.., tap, tap, tap tap). While I could imagine it to be slightly faster, I don't think the difference would be significant.

I have read a few more folks mention performance issues on HD10 - even though it is higher spec'd hardware. I don't have an HD10 to test with. Let's see if there are other observations.


Officially, we do not recommend loading the Play Store or any similar hacks. Being "factory standard" helps ensure you can replicate the same experience we have. 

How do you install Fully without the Google Play Store?

Using Silk,  find the download box on the Fully Website (several versions are listed).


You download the APK for FireOS and just open it to install.

http://www.fully-kiosk.com 

I am new to Action tiles and Fully.  I have both installed and working on an 8th gen Fire HD8.  I installed Fully using the APK from their site.  Is there a list of currently recommended settings to optimize the ActionTiles Fully experience?

+1

There are really very few recommended settings because it depends on how you are using your Tablet and whether or not you wish to purchase the "PLUS" License upgrade (from Fully themselves, on a per-Tablet basis!).

But let me try a quick outline to start and we'll refine this into a KB Article:

  1. You'll probably want to set the Tablet to Developer Mode (FireOS Settings, Device Options, tap Serial Number 7 times, Developer Options: Stay Awake (Screen will never sleep while charging).
  2. Fully Settings - Web Content - Start URL:  OK to use https://app.ActionTiles.com ; but better to use the complete URL to your desired Panel (get this from the Address Bar in Silk or Chrome, etc., by visiting your Panel). Every Panel has a unique URL, that looks like:  https://app.actiontiles.com/panel/7dab37f2-7fb8-afaf-9191-90d20505aa2e
  3. Wait for Network Connection: Off
  4. Web Zoom and Scaling: Leave these default; but you can experiment with them after everything else is working. For example, turn Off "Use Wide Viewport" and then you can see the effect of changing the Initial Scale value. This can sometimes give you more fine tuning over the fit of the Panel. The Set Font Size option can also be fun to explore.
  5. Web Auto Reload: Use defaults (all Off).
  6. Screensaver (PLUS): To have it fade to black screen, set a Timer value, and set Screensaver Wallpaper URL to:  fully://color#000000
    To have it use some other Screensaver, try different Wallpaper URL values and/or explore the Screensaver Playlist option. In fact, explore all the options, but first note the defaults.
  7. Device Management: Keep Screen On - On (may not be necessary, see #1). Screen Off Timer - 0 (disabled) otherwise lock screen swipe will be required. Launch on Boot - On. Screen Brightness: Probably not needed if you use the default FireOS-Android control of brightness or automatic brightness.
  8. Power Settings: Keep defaults (all Off). Scheduled Wakeup and Sleep - Do not use this on Fire tablets as it overrides the Never Sleep setting and you will face the Lock Screen daily. All other options are also best left Off (default). WiFi Wakelock might help if you find ActionTiles disconnecting too frequently.
  9. Kiosk Mode (PLUS): Extra lockdown functionality. Don't explore this until you're sure what you're doing.

  10. Motion Detection (PLUS): This is the nifty "wake on front camera motion detection" (instead of requiring tap to exit screensaver). Experiment with Enable Visual Motion Detection and the tuning options. This can use extra power and cause the tablet to heat up more, and does not work if there is no light for the camera to use to detect motion. Turn Screen On Motion - On; Exit Screen Saver on Motion - On.
  11. Remote Administration (PLUS): No need to enable.
  12. Other Settings: Enable Version Info - Off. Show Menu Hint on Start - Off. Enable Settings Auto-Import - On: But beware that you may need to delete fully-settings.json if you want to completely uninstall and reset Fully to its defaults.

Hope this draft above is helpful. Let's figure out if I've picked any poor choices.

...Terry.

OK, just from reading this I want to confirm that if you use the fully schedule to power off and then back on in the morning for instance, that there is no way to have the Fire HD10 go automatically back into Fully instead of the normal Fire 10 Android lock screen?  If this is the case, do you just recommend doing the screen dimming trick?  Was hoping by shutting off when not around, I would prevent from killing the battery from overcharging.

ok when I use google chrome with action tiles my video feeds from my Wyze cams show up just fine. However, when I use fully kiosk, it won’t display video feed. Anybody know what the problem could be?

Fully is powered by Android Webview (based on Chromium), but is technically an older version of the browser engine than Chrome (which always has the latest stable Chromium). On FireOS you cannot update Webview - on some other Androids you can.


That is one difference, though it should not cause a particular problem. I use tinyCam with Fully just fine (using a slow frame rate "&fps=1" in the URL.


Be sure to not use "//user:password@address" URL format, of course.


how Would I set up tiny cam with full?

So, I have everything setup and working great except for ONE minor issue - Fully seems to crash out regularly.  Restart it and it's all hunky-dory, but let it sit for awhile and it drops to the launcher w/the screen completely dimmed (since it was in the dimmed screensaver).

  • What type of Tablet?
  • What modifications / hacks on the Tablet?
  • What version of Fully? (I may help to use the FireOS APK from their website)
  • How complex of a Panel? Any Media Tiles? - i.e., please test with a simpler Panel for a while.
  • Test with a different browser to confirm it isn't an ActionTiles issue.
  • Uninstall and re-install Fully.
  • Factory reset your Tablet.

We (ActionTiles) can't really help with Fully issues - it is not our App. Be alerted: you should avoid telling Fully Support you are using ActionTiles because they may kick the issue back to us, and then you are out of options.

For me:

  • Fire HD 7, 8 & 10
  • Latest version of Fully.  Have tried both the FireOS APK, and from sideloaded Google Ply - both freeze.
  • It is complex, with 4-5 Camera Media Tiles.  Using 5 second image resfreshes, not direct stream.  Still hangs when using only 1 camera media tile.
  • Will see if I can test with Chrome on a Tablet-- my suspicion is that it's Fully.
  • Have uninstalled and re-installed multiple times, and factory reset a bunch.  Fully still freezes again with the next 24 hours

This is clearly a Fully issue.

I have been trying to find a solution for this for a while too.  Fully would crash almost non-stop (I could see it from the dinner table and it would just crash, reboot, crash, reboot).  Other said the the dev was willing to help with these kinds of issues to folks who had paid for multiple licenses but seemed barely interested in responding to me, pointing fingers back at the Fire tablet and AT when I had reached out to him.  He said it was due to an older version of Android WebView, but I would assume that Silk uses this same component and has no issues for me.  I would also get a "Camera failed. Trying to restart..." error constantly with Fully that I haven't seen in months now since switching to Silk.  I really wanted to use Fully because the screen dimming and motion detection features are awesome.

  • Three different HD 10s -- identical issues on all three.
  • Two bone stock, one had Google Play side loaded -- made no difference in stability.
  • Used both versions available on Google Play Store and FireOS APK from their website -- made no difference in stability.
  • Also rather complex w/six media panels (three weather images and three cameras) 
  • I switched to Silk for 3+ months straight on all tablets with near zero stability issues (just loose the screen dimming and motion detection -- which is a major loss).
  • Uninstalled and reinstalled several times -- no help.
  • Factory reset several times as well -- no help.

What version of Fire HD tablet(s) do you have?

This is NOT a widespread issue or we (and Fully) would have a LOT more inquiries about it. Fully on Amazon Fire Tablets is the top combination used by ActionTiles customers!

We have almost the same setup with tiles, cameras, and tablets.  FULLY crashes worst on the Fire HD 10s than the others.  Have your tried ActionTiles on Chrome, or do you like Silk better?  


I may dump the FULLY browser as my wife and kids can't deal with Fully crashes and not access the key info and buttons needed.

Give this a try: "WallPanel" kiosk App.

I have known about it for a while, but not heard of any Customers trying it - until today.

If it seems to work out for you, we'll start a separate Topic, to chat about the results and pros/cons.

PINNED

Hello,

I'm developer of Fully Kiosk Browser. If Fully Kiosk crashes sometimes we recommend re-install Fully and run a simple website like www.google.com for a couple of days. If Fully Kiosk doesn't crash then the issue is probably the complexity and behavior of the website which leads to crashes in Android Webview. Unfortunately we can't  catch, analyse or fix anything in Android Webview. It's completely out of our control. The problem is even worse on Fire OS as a slightly outdated version of Android Webview is installed and can't be updated separately. 


Silk Browser doesn't use Android Webview according to these FAQs, so the results in Silk can be different.

https://developer.amazon.com/docs/fire-tablets/web-hybrid-app-faq.html

Another common source of non-reproducible crashes is the device overheating when visual motion detection is used. Try disabling motion detection. The tablet devices and cameras are usually not designed for running 24/7 at all. Please try running Fully Kiosk on another device type using Android OS (not Fire OS).

Alexey

So, since my last post (which I don't think I replied correctly to make it go into this part of the thread) I've run things for awhile and what I've found out is the following:

  • ActionTiles screens with no images don't crash over the span of a few days.  
  • My 'main' screen with 4-5 images crashes regularly.  Normally <1d, sometimes in a few hours.
  • One of the images (an animated weather image) recently stopped loading (from radar.weather.gov) and now Fully hasn't crashed in a few days - since it stopped loading.  There is another animated weather image on the page still (from wxug.com).  

I'm up to date on Fully, Webview is the older one that's on the Fire 7 (2017), and it's wall mounted with a lot of airflow/space (just on some holder things - not encased in wall).  Been using camera motion detection the entire time as well.  So, just some additional details.  

Hello Bob, from my measurements having even one animated element on the webpage raise significantly the CPU load of an Android device. This could be source of overheating or other issues. Try avoiding animated elements just for a test.

I have this problem as well.  One thing I did was go into the Fire Tablet setting and delete ALL settings and cache for Fully. That seems to help for about a week. a bit of a pain.

It's a Fire Tablet 7 (2017) w/Google Play installed and Launch Hijacker to use a different Launcher.  And my panels have a few media tiles as well.  Let me test with a different browser and see if it works.  It does seem to be happening more and more, so maybe it's cache related or the like. 

I didn't notice this happening with the ActionTiles version of Fully, but I also only ran it for a short period of time before switching.  

Hi All,
I setup my kindle fire 8 with action tiles and fully kiosk and it's charging all time .
After a while the touch starting to be not responsive and not sensitive when plugged into the charger .

When I remove it all OK .
Did anyone have this issue ?

Terry,

Hoping you have some insight. Been using Fully with ActionTiles on Fire7 tablets for over a year and really like the setup. Only issue I have is changing SHM state. I have a passcode setup for this tile and about 50% of the time Fully crashes after entering the code. Not sure if this is a Fully or ActionTiles issue but I don't see this issue on other tiles that are not passcode protected. 

We're a little nervous about Fully over the past few months; perhaps newer versions are using too much RAM - which can really be a problem on low-end tablets like Fire HD7. I only use HD8 myself, and don't have problems (though Hue App runs horribly slow). We have not had any other reports of PIN Protected Tiles crashing; but non-specific issues with Fully and/or Fire HD7 (and sometimes HD10?) are not uncommon to hear about.

To confirm it is not a problem with Android Webview (the underlying browser engine used for all embedded browsers like Fully and more), please test another Webview based browser like WallPanel:  https://play.google.com/store/apps/details?id=com.thanksmister.iot.wallpanel&hl=en_US

Please write to Support@ActionTiles.com if you have a somewhat consistently replicable case and include a lot of details. If we can't replicate it, we can't fix it. Fully's developer can run diagnostics, but will hesitate to do so for a single inconsistent problem on a single website.

+1

Fully has been a ongoing issue for me relative to battery management, reboots, empty tiles and restarts. For the dev to say "...just reinstall and load Google for a while.." on a paid app is less than ideal. Downloaded Wallpanel and will monitor that this week.

Hello Terry and Shaun, if having any unspecific issues with Fully Kiosk Browser please first disable the Visual Motion Detection. This is the only feature in Fully Kiosk which can be somewhat CPU and RAM intensive and can make weak devices like FireHD significantly slower. If your device still shows any issues when running over long time please try loading a simple website like www.google.com and run it a couple of days. If no issues occur it's very likely that Android Webview is a kind of overloaded with your website and can cause different issues which are however out of our control. We can't change anything on the Android Webview unfortunately and Fire OS is even using not the latest one. On other Android devices some users reported better results when running outdated versions of Webview as the new versions were buggy. On FireOS you can't downgrade the Webview however. Alexey

So yes it appears that VMD has a negative impact on battery endurance on the Fire HD 8. After disabling this I have had no issues at the same drop rate so far.  It’s been 4 days and the battery has dropped from 100% to 90%. Not ideal but a big step forward. I’d recommend this is posted as an exclusion on the Fully site as someone like me that paid specifically for VMD in the PLUS version is unable to use it. 

You are plugged in continously, right? 

I have motion detection wake on my Fire HD8 at battery remains at 100%. Even have 2 camera streams. Everything is stable.

Hi Terry,
Do you have some touch issue when your kindle fire plugged in  for example when you need to type the code for protected tile ?
For some reason my kindle the touch is not fast enough and feeling strange when plugged to the charger 

I have not experienced this on a Fire Tablet (what model?); but it is not unheard of for some Tablets to have touch screen or other issues when plugged in, especially if the power is insufficient or there is some other defect.

I recommend factory resetting your tablet and/or trying other USB power supplies, or replacing the Tablet.

Thanks Terry ,

I did factory reset and still the same .

probably a defect unit :-(

+1

Terry,

I installed WallPanel yesterday afternoon and so far so good, no issues with the passcode protected tiles. I will continue to monitor. Thanks for the quick response and suggestion. 

Hi,

Fully  kiosk Browser 1.33 has been crashing on Fire 5.3.6.4 recently. Anyone else?

yep. I have 4 and all are crashing

Hello, I don't see any crashes on my test device and I don't receive any crash reports regarding Fire OS with FKB 1.33. Please contact me at info@fully-kiosk.com and let's check the issue. Alexey

Sorry I should have clarified. I don't think Fully was the issue, nor do I think it was actiontiles Something was going on last night that caused all my devices to crash. The only thing in common is they are all Fire Tablets and all running Fully. I did notice one of my pistons not working as designed last night as well. I have been running both for over a year and aside from one actiontiles outage this combination of devices, browser and actiontiles has been solid. As of now all devices are running just fine again

+1

I use a Fire HD 8 with Fully and notice that my tiles on lower right hand corner of screen are not rendering properly - they look jagged. The problem gets fixed when I change graphics acceleration in Fully from hardware acceleration to software acceleration, but then Actiontiles run sluggishly. 

Anyone else having similar issues and any recommendations?


I think this is a Fire bug. Hopefully an update will fix it. Just guessing. 

I have this issue too. Only happens on 1 of 4 Fire tablets.

I just picked up a Fire HD 10 (2019) in the sale but I'm disappointed that Fully is only displaying Actiontiles in 1280 by 800 instead of the full screen resolution of 1920 by 1200

Anyone know a way around this?

+1

A long discussion on the difference between Android "display pixels" vs "physical pixels" is unlikely to be practical here so I'll offer 2 practical solutions:

1. In Panel Settings (for each Panel) just reduce the Tile Size, Font Size, and similar settings to fit more on the screen. The full resolution of the screen will be used (i.e., sharpness will not be reduced).

and/or

2. In Fully, 

  • Swipe from the left-edge to get to Fully Settings menus.
  • Select "Web Zoom and Scaling"
  • Shut-off "Use Wide Viewport"
  • Experiment with different values of Initial Scale (sorry I can't tell you what exact number works; it's always been a little confusing to me. But like everything we recommend exploring because you may discover that certain values are useful in the future, etc.).  Start with values like 80, 120, 200.

...Terry.

Amazing spent over a hour googling and looking at all the settings in fully but turning off use wide viewport and setting the scale to 100 it is displaying how I expected it too

Thanks for your help and the amazing actiontiles

Glad to have helped.  A little confused, because "100" should be the default value used by Fully ... but I'm never one to argue with what ends up working. 🤗

Not sure about Fire HD devices. Usually issues like this can be solved by HTML means by using something like this:

<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

Usually no need to tweak the scaling settings in Fully Kiosk.

I purchased a Fire HD 10 to use primarily for ActionTiles and DAKboard through fully.

What’s the most current guide for converting a stock Fire Tablet for this purpose?

There is no "conversion" necessary nor recommended.

  1. Using FireOS Settings, activate Developer Options Menu by tapping the Serial Number (under Device Options) 7 times.
  2. Set Stay Awake on (Screen will never sleep while charging). This is the simplest way to avoid the "lock screen". There are no other reliable ways. I've heard of a background App that will force stay-awake, but it is not necessary and is likely a battery drain.
  3. Using Silk, download the FireOS version of Fully from the "Download Box" at https://fully-kiosk.com 
  4. Explore all of Fully's options. We do not "support" Fully, so we want you to be familiar with all its powerful options (but change as few options as possible).
  5. Swipe from the Left-Edge to get to the Fully settings.
  6. Set the Start URL to the exact URL of the Panel that you wish to use. Get this URL by visiting your Panel in Silk and highlight the entire URL from the Address Bar, hold, and Copy to Clipboard. Then paste into Fully's Start URL.
  7. Fully has an entire page to configure Screensaver. This is a (PLUS) feature which will require a Fully License per Tablet.
  8. For just screen dimming, set the Screensaver Wallpaper URL to "fully://color#000000". For DAKboard, use your DAKboard's web URL.
  9. Fully has an entire page to configure Motion Detection (i.e., wake on front camera motion detect). This is a (PLUS) feature which will require a Fully License per Tablet.

Please let us know if any of the above Steps require elaboration or if you have further questions. We will then publish this as a Knowledge Base article.


Thanks!

...Terry.

Thanks. Those instructions worked great.

I do use DAKboard as the screensaver, but is there a way for the screen to completely sleep at night and wake up in the morning, or at least go black?

If you use the Fully "scheduled sleep" option(s), then you will have to swipe to unlock the lock screen in the morning.


For just screen dimming, set the Screensaver Wallpaper URL to "fully://color#000000". For DAKboard, use your DAKboard's web URL.

I don't think you can schedule different screensavers. Perhaps that will be a future Feature.

In the meantime, you might also contact DAKboard support to see if they offer full black as a scheduled option.

+1

The Power Settings>Schedule Wakeup and Sleep (PLUS) settings work great. I'm going to give that a try for a while and see if I mind waking it up every morning. I looked into the DAKboard option too. I can schedule a black rectangle over the entire screen as well. I test it and it worked great. Thanks!