Answered: Discussion Open

Fire daily Alarm kicks in the lock-screen?

Terry (ActionTiles) (Co-Founder) 6 years ago in Browsers Tablets Phones / Amazon Fire updated 6 years ago 2

Continued from: 

Various folks have mentioned that even with "no sleep when powered" setting enabled, and running Fully constantly, etc., Amazon Fire tablets still seem to switch to the lock-screen overnight or some periodic basis.

Myself and Jeremy have noticed that there is an Alarm icon in the Notification Bar that coincides with the timing of the issue. Not sure this is always the case.

The problem is that the Alarm has no discernable source. Googling is inconclusive so far.

Any ideas? 


This may actually be Fully related.  I have no alarms configured on my tablet, but I have the icon at the top too.  This is because in the Fully settings, you can enable "sleep and wake" times.  This automatically turns the screen off to "sleep" and turns it back on to "wake".  When it wakes, it goes to the default lock screen until you unlock it.  It's in Fully-Settings-Power Settings-Schedule Wakeup and Sleep (PLUS).

Side note: I use this Fully feature to have mine setup to sleep every night to help avoid burn-in and/or premature screen failure.  If you do want to use this feature, you must use 24h time format (HH:MM).

Answered: Discussion Open

I'm pretty sure you're right, JB! Thanks for this clue.

I uninstalled Fully and immediately the "Alarm 04:00" disappeared. I reinstalled Fully and reloaded my Exported Settings and the Alarm reappeared.

Browsing the various menus, I could not find the "sleep and wake" time(s); but in the Exported Settings .json file, it is pretty darn obvious, particularly since the time of 04:00 matches:

"sleepSchedule": "[\n  {\n    \"sleepTime\": \"04:00\",\n    \"wakeupTime\": \"06:30\",\n    \"dayOfWeek\": 8\n  }\n]",


I found that there was a Sleep Schedule entry and once I removed it and saved settings the Alarm Indicator went away. Let's see if Fully stays "awake" overnight this time.