0
Discuss & Vote

SmartThings scenes look different and don't appear in ActionTiles

rsantone 2 weeks ago in Panels (dashboards) / Special Tiles updated by Alex (ActionTiles) (Co-Founder) 4 days ago 36

I had a few, I guess "routines" in the ST Classic. "Goodbye" turned the heat down and set the mode to Away. "I'm Back" turned the heat up and set the mode to Home. Apparently something in these prevented migration to the new app so i deleted them and remade "Scenes" that did the same thing. They look different in the app, and don't show up in ActionTiles. What can I do? I've attached a pic.

+1
Discuss & Vote

Hi,

The routines tiles are now deprecated and will be removed from ActionTiles is the next couple of days.

The Scenes need to be authorized separately from devices. This integration is available under My Scenes (beta) menu item. Please note that this integration may not work for you. We are working with SmartThings support to make sure it's stable before it can graduate out of "beta".

Thanks

Alex

I found the My Scenes (Beta) and authorized whatever it asked me to but I still can't seem to add my new ones. Are you saying my remaining ones will stop working soon? Why did this all happen?

Hi,

Routines are being deprecated by SmartThings as a result of migration to the new SmartThings app. All Routines will stop functioning on October 14, as announced by SmartThings. You should have received a notification from them about this and other changes.

Do you see any locations/hubs listed at https://app.actiontiles.com/scenes? This list should contain your scenes, assuming you were able to successfully authenticate with the new SmartThings platform.

+1

I've seen some e-mails go by about new apps. When I got a Smartthings years ago there were two apps and I didn't know the difference and certainly didn't I needed to "migrate" and change everything.


No, hubs show up in the scenes menu. I click the orange "Add Smartthings Hub" button, sign in, and authorize access to locations and scenes but when I come back, nothing is there.

I can add new tiles with new scenes but for some reason it doesn't let me delete anything. If i try to delete the old routines it asks me for confirmation but nothing really happens...

UPDATE: Now when I try to delete the deprecated scenes it's deleting other random things in my panel!! PANIC

I'm having the same issue as you are, can't delete what I want to delete but it's deleting random stuff or nothing at all. Can still delete entire tile sets, though. So as a work around you can build a new tile set without the tiles you want to delete and then delete the wrongly configured old tile set, PITA but it helps to retain a clean Action Tiles display.

Edit: Found a simpler way;

create a new tile set

add a blank tile

move all unwanted tiles into new set

delete new set

profit.

Thanks a lot Munter! good workaround

Alessandro, this bug was fixed this morning.

I did the same with Add Smartthings Hub and authorize location and scenes, but no scenes/hubs are showing up in My Scenes. Tried authorizing multiple times.

+2

Same with me. I go through the authorization, but none of my scenes show up in actiontiles. 

Likewise.  Interestingly, if I authorize a second location that I have in my account, that one works.  Just not my primary location (where all of my devices are already

Hi David,

Are you able to check whether your two locations are on different shards?

Thanks

Every time I try to add scenes, it asks me to Authorize.  I've been though the Authorize routine at least a dozen times.  The scene list remains empty.  I created a new scene in ST and it showed up as a "sun" icon.  (The older scenes show up as a "star" icon.)  The new one didn't show up in AT either.  The list is still empty.  

So is this a Smarttthings issue or an Actiontiles issue? Seems there are quite a few people that are going through the authorization process for scenes but nothing is showing up for them. This has significantly broken the functionality of the tablets I'm using for control in a few rooms.

Are there workarounds? Can we still create virtual switches and have those kick off the new scenes? I hate to have to go through that, but it's frustrating to not be able to control some light groups now in my kitchen and living room, and the family is even less understanding than I am about the situation. 

As I understand it, SmartThings retired the Classic App which used Routines.  ActionTiles were tied to Routines.  ActionTiles is working on a new way to tie into the New App Scenes.  In the ActionTiles menu, it says, "My Scenes (beta)."  So, it is still under construction.  In my case, it seems to be failing to Authorize.  

So, I believe the issue lies in the communication between SmartThings and ActionTiles.  So, the answer to your question would be both / either.

I have not tried it, but it looks like we can create virtual switches.

There has also been some talk about sending a web request to the SmartThings API.  I will have to do more research on that one.  Does anyone know if ActionTiles can send a POST / Web Request?

I have to say it's disappointing that ActionTiles wasn't ready for this thing that's been coming for a while, and it's incredibly disappointing that Samsung felt the need to change everything up when it was working just fine. 

Native Scene integration was available since Aug 21, 2020. However no one really attempted to try it until the eve of the migration deadline.

Please read my comment below. I invite you to politely voice your disappointment to SmartThings using your favourite communication channel. I can only hope that pressure from users will make them open up the New API.

Thank you for the update. I'll start with polite.

I think we'd all like to voice our disappointment to SmartThings.  But a unified approach may have a stronger effect.  Do you have a link to a specific discussion we can upvote?  (100 upvotes on a single ticket will go much further than 100 tickets on the same issue.)

From where I stand, the problem is with SmartThings as their API is not production ready. 

The following article describes a workaround to integrate Scenes using virtual switches.

https://support.actiontiles.com/knowledge-bases/8/articles/8740-how-to-use-new-smartthings-scenes-with-actiontiles


There's a way to run scenes using Personal Access Tokens with the New ST API. However it is possibly even less user friendly than the above method. If everything else fails, the web request method should also be explored.

To be clear, I'm not a programmer.  I have some experience with VBA and Arduino, but very little with HTML / cURL, etc...  This is what I've learned so far...

Yesterday, I was able to run scenes in WebCORE using these settings:  

With Location, 

Do "Make a Web Request"

URL value = https://api.smartthings.com/v1/scenes/{SceneID}/execute

Method value = POST

Send Variables = {blank}

Request Body Type value = JSON

Authorization Header value = Bearer {TokenID}

The instructions to generate the TokenID and retrieve the SceneID were fairly straight forward (Even I was able to do it...)

The only piece of the puzzle missing is an equivalent command in ActionTiles.  

I've seen a lot of requests / upvotes for such a feature.  Maybe it's time to give us a tile that will handle Web Requests in a similar manor as WebCORE.  That would allow us to run scenes until SmartThings fully develops their API, and will make a lot of people happy.

Reference:   https://support.actiontiles.com/communities/12/topics/2475-run-webcore-pistons-from-actiontiles.  Web Requests are discussed near the end of the discussion.

Reference:  https://community.webcore.co/t/can-we-activate-a-scene-in-webcore-using-new-st-app/10475

+1

This kind of tile was developed some time ago but was never released because of some security concerns. Since then it fell through the cracks and got abandoned. I need to revisit that code and resurrect it.

You can do the same thing in ActionTiles using a shortcut with the URL format:

javascript:$.ajax({type: 'POST', url: 'https://api.smartthings.com/scenes/abcd1238-1234-5678-abde-f84273f21e21/execute', headers: { 'Authorization': 'Bearer 234dcbfa-c764-4534-8f4e-57f634ad1867'}});

I guess your mileage may vary.

Not a single reply from AT on this? Very disappointing and only adds to the frustration 

You are not alone, Will. For every post in this thread there are dozens of other posts across the social media and private tickets. This is a very frustrating time indeed.

Same here... I can authorized all I want, but it doesn't add any Scenes.

My apologies for a delayed response. I needed to verify some things before writing this post.

With the looming deadline of Classic mobile app migration more users attempted to authorize Scenes. The Scene integration is only possible using the new ST API.

As it turns out, there's a limit on the number of installations of the new SmartApp. However, SmartThings would not lift or increase the limit because... the New API is not ready for production!

I'm trying to negotiate and pull some strings, but so far I haven't been able to find a solution.

It looks like the native integration with Scenes needs to be pulled from ActionTiles.

At the moment, the only way to add Scene tiles remains the method described here:

https://support.actiontiles.com/knowledge-bases/8/articles/8740-how-to-use-new-smartthings-scenes-with-actiontiles

+1

Disappointing to have put this much work into this deployment and now are hanging on waiting for a fully cooked API. I think we deserve an honest timeline when we can expect full function. 

+1

I'm not able to offer a timeline because the dates are often arbitrary and constantly shifting. But yes, it's disappointing to have invested so much time while there are so many other priorities.

+2

I sent a nicely worded and articulate message to ST support about my problems, others problems, and the explanation given here by Alex. I just received this back:

"Sorry for the inconvenience with the Action Tiles in SmartThings App. We are forwarding this to our Developers team as a feedback so they'll work on it and might implement the changes to support full functionality of Actin Tiles in future App updates."

+1

If you share a link to your request, we can up vote it. Maybe they'll look at it sooner. 

The native Scene integration was rolled back on October 18 until farther notice. It will continue to work for those who already authorized their locations.

Meanwhile the following workaround remains available:

https://support.actiontiles.com/knowledge-bases/8/articles/8740-how-to-use-new-smartthings-scenes-with-actiontiles

The method described above is sub optimal, however it's the most "user friendly" method to integrate the scenes. It's much less involved and dummy proof than running a scene via HTTP webhook.

This is horrible timing for me. I just set things up with ActionTiles, paid for it after trail license, bought a new tablet to mount on the wall and just as I thought everything is ready to go the routines stopped working. I see a message when I login saying action tiles will be going down on Oct 20 for maintenance, is that related to the scenes release?

The maintenance on Tuesday October 20 is due to server migration. It will be done in response to recent performance issues we encountered.