+2
Discuss & Vote

Images on media tiles are not loading on Google Chrome browser on PC

sk108 1 month ago in Media Tiles / Images updated by bd0g 1 day ago 14

Images on media tiles are not loading on Google Chrome browser on PC, however they load on the phone browser. When I try to edit those "Media" tiles, it says "Enter valid URL". Please note that the URL is valid and that media tile is showing correctly on the Android phone browser (Google Chrome). It is happening with all media tiles on the PC browser. It used to work fine till last week on PC as well as on phone. Please help, thanks in advance.

Discuss & Vote

Hi,

Please check if you are able to view the images on your PC using the Chrome browser directly, rather than via ActionTiles app. It's possible that the phone and the PC have different types of access to the network resources.

Yes, I can view them directly in the same browser. Both PC and phone have same access, also they are on same wifi network.

It doesn't have any embedded credentials. However, that url fetches details from a google sheet and outputs it as an image. I am still unsure why it is working normal in another tab in the same browser, but not working on media tiles. Previously it used to work perfectly.

I was able to solve this by going in to site settings for actiontiles.com in chrome browser and by allowing "insecure content".

Could you please send me (privately) a sample of such image URL?

Previously ActionTiles was able to display "mixed content" without any issues. Mixed content are resources served over HTTP to HTTPS sites. I wonder if browser policy has now changed to disallow that.

How to share the link with you privately? Can you please elaborate so that I can share the link with you.

It appears that in a move for a more secure web, Chrome no longer allows to display images that are served over HTTP. It tries to upgrade the connection to HTTPS, but if the server is not able to respond, the image will not be loaded.

This is going to be a major problem for ActionTiles users who often use video camera streams on local network.

If I find a workaround for this, I will post it on this forum.

Thanks Alex. For now I have enabled SSL certificate on my domain. Please keep us posted if you figure out something else as well.

Thanks,

Satyam

Had this cause me issues as of today, its not really a "Fix" but you can get around it by allowing mixed content for just app.actiontiles.com

Some instructions from Adobe (just do this on your action tiles web page instead) : https://docs.adobe.com/content/help/en/target/using/experiences/vec/troubleshoot-composer/mixed-content.html

Now I'm off how to find out how to upgrade my BlueIris to do HTTPS

I already did this. However, sadly there is no such option on mobile chrome browser. BTW, I have now enabled SSL certificate on my hosting.

Thanks for this!  I just ran into this very issue trying to embed images from my local WeeWX weather station server.  I marked the lone panel as mixed and bam.  Now if I can get the generated current weather RSS feed to work like the example RSS feeds..

Some users reported that mixed content sill works using the Samsung browser. To my knowledge this should also work in Firefox. For now, anyway.

This solved my embedded Media Tiles that point to my Amcrest Camera Live Video that were not showing up and appeared as a broken link. I just added 
https://beta.actiontiles.com under Settings - Insecure Content - Allow

It did not fix the link that points to my BloomSky Camera that used to work as a .php link as a Still Image or Gif within a Media Tile. I can visit this link http://bloomsky.rf.gd/bloomSkyLatest.php?i=0 in my Chrome Browser and it is displayed , however when I add it as a Media Tile it will not display. I added http://bloomsky.rf.gd in the same manner described above to allow Insecure Content , but it did not resolve it. This link used to display without issue.