+13
Fixed

v6.7.2 Glass UI: Broken functionality on older iOS devices

Derrick Ho 7 months ago in Browsers Tablets Phones / Apple • updated by Alex (ActionTiles) (Co-Founder) 6 months ago 21

This update broke the UI on older devices.

I have several iPhone 5C devices and this update has broken the PIN entry UI.  The numbers  are missing except for 0 which is partially cut off.

This is using safari and I can not use a different browser.

I have tried quitting and relaunching the app but it still doesn’t resolve the issue.

iOS

Answers

PINNED
Confirmed Bug

Thanks for the report, Derrick.

We have replicated this (I luckily happen to have an old iPad sitting around; geesh - we should have checked this, sorry) and are analyzing and researching.

Our analytics indicate less than 1% of Customers may be affected. We cannot promise a quick solution. It is too early to tell what type of "old Safari" incompatibility glitch we have stumbled into.

Please stayed tuned to this Post for updates.

...Terry.

+1
PINNED

Partial fix has been deployed:  v6.9.2+033 (Your Panels will upgrade automatically).

Fixed:

  • PIN pad
  • Dimmer
  • Color selector.
  • Routines List.
  • Modes List

PINNED
Confirmed Bug

Thanks for the report, Derrick.

We have replicated this (I luckily happen to have an old iPad sitting around; geesh - we should have checked this, sorry) and are analyzing and researching.

Our analytics indicate less than 1% of Customers may be affected. We cannot promise a quick solution. It is too early to tell what type of "old Safari" incompatibility glitch we have stumbled into.

Please stayed tuned to this Post for updates.

...Terry.

Hi, I just want to add that google chrome and Microsoft Edge also have this issue on the iPhone 5C.  So this rules out any Safari specific issue.

Thanks for the note, Derrick...


In the case of iOS, if my knowledge is correct, Apple does not allow alternative browser "engines". These other browsers actually just layer on top of the Safari engine. Just like most (but not all) Android browsers are a layer on top of the Android Webview engine.

Would it be possible to have the option to use  “legacy” PIN ui?

That may turn out to be the most expedient solution.


It is quite a bit of coding to have both UI's available for every applicable Tilebut if a fix for Glass UI doesn't look promising, then we'll certainly look at pragmatic options.

I have a same issue on Samsung tablet.

No color wheel on rgb lights, no routines, no SHM. Just partially visible parts of screen. Looks like everything is cut off. 

Hi Milan:


What specific model of Tablet and exact OS version, please? You can find this under the Settings pages ⛮ for your tablet (likely available if you swipe from the top edge and tap the gear...).


What browser are you using?

Can you please try a non-Chromium browser (eg Firefox) as a diagnostic for us?

Thank-you, 

... Terry.

It's Fully Kiosk browser on Android 4.4.2, on Samsung Galaxy tab Pro 8.4.

I like using fully kiosk, because of my screen saver - Dak board

I'll try my other tablets, later


Chrome works (on the same Tablet)

Thanks for the depiction, and for the details, Milan.

Fully (and the ActionTiles Play Store App, actually) runs on top of the "Android Webview" engine, which is built into the Android OS. Unfortunately, Webview cannot be updated separately from a complete Android update, except if you have Android 5.0.

We cannot guarantee compatibility with "older" tablets and OS versions, but generally have believed that Android v4.4.x and above was sufficient. Even a point above might be helpful in various cases (e.g., v4.4.3 instead of v4.4.2); but we don't know exactly when the browser was "fixed" to be completely compatible with the widgets we are using.

We have some leads and have made some progress testing some fix ideas on old iOS, so hopefully these same fixes will be applicable to you. If not, it may be worth researching XDA Forums (Google them, please), to see if there is a way to update the OS level on your Samsung Tablet(s).

Please stay tuned to this Topic.

+1

And on second take, Android Webview appears to have fixed it. I updated it, but didnt reboot. 

Hi Matthew,

So, let me confirm... You got it working on the Android device, only the iOS device has this problem. Correct?

I'm purchasing an older iPad tomorrow so that I could reproduce this error.

Alex

Sorry, didnt see this until today, but yes. Should be noted, I'm on Android 5.1.1 though, so it may still persist for those on Android 4.x.
Chiming in here, same issue on two iPad 4's. Cheers!

Thanks, Gmau....


We encourage use of the VOTE button, as it gives us a quick count of both affected Customers as well at their personal impact (1 to 3 Votes):   image.png


The good news is that we have a partial fix staged in Beta and it is stable enough that we will deploy to Production soon. This partial fix has given us clues as to what might be a complete fix; though we still have further research to do.

+1
PINNED

Partial fix has been deployed:  v6.9.2+033 (Your Panels will upgrade automatically).

Fixed:

  • PIN pad
  • Dimmer
  • Color selector.
  • Routines List.
  • Modes List

looks fixed on iPhone 5c.  

this is resolved for me, thanks!

Commenting disabled