+12

Here is how to View Ring Doorbell alert with ActionTiles

jgirvine 12 months ago in Media Tiles / Video Camera Feeds • updated by tm8747a 4 months ago 17

I posted last night on Facebook about being able to have the Ring App open and close automatically on an alert on a tablet dedicated (or not) to ActionTiles. Here is a very poor video I shot showing what I have setup.  Video  First let me give credit where it truly belongs.  The Solution 


For those who asked for more detail I am providing here.  I have 3 tablets in my home dedicated to ActionTiles.  Two are Samsung and one is the Amazon Fire HD 8.  All are setup to run ActionTiles using the Fully Kiosk Browser set to motion activation, so when the tablet detects motion ActionTiles opens.  Fully   I am using the Pro version as that is what is needed to have it motion activated.  Then within Fully you can setup a screen saver. 


For that I am using the free version of DakBoard.  Basically you setup an account online, choose what you want the screen saver to show, then get the URL and paste that into Fully.  Dakboard.  Of course you need the Ring App loaded.


The app that really makes this work is AutoMateIt  (free version) with AutoMateIt you set up rules to open and close the Ring App.  You need 2 Rules.  One to open Ring and one to close.  click on the plus sign and under the Trigger Tab choose Apps - "Notification Trigger".  On the next screen choose using the magnifying glass the Ring app, click "Next" then choose "Start Application Action" and again choose "Ring" with the magnifying glass.  Click "Next" and enter a name for your Rule and click the "Save Icon".  That will now open the Ring app when a notification comes in from Ring that you have motion or doorbell rung.  Now setup a second rule, choose the Ring app on the first step, so that a notification from Ring will trigger this rule, but under the Action tab choose the Fully app, and on the page where you enter the Rule name choose the "Delayed Execution" option and one minute, then Save.  The second Rule will then reopen ActionTiles on Fully after the one minute mark.    It is not perfect, and I have had some hiccups where it will open the Ring App on the list of devices page and not the view screen, but I would say 90% of the time it is working.  

Fire Android

Wonderful information - I used all of this to get my Kindle Fire tab setup using Fully, Automate, and the Ring App. It's working well -  but I have a question. How do you keep the screen on the Kindle Fire from locking (swipe to open)? I have set the screensaver as Dakboard, do you just leave the screensaver on at all times? Can you make the screen go dim yet not shut off?


Thanks so much - this was great!

I got this all working last night on a Fire 8. Seems to work pretty well and I appreciate the information. This is exactly how I wanted things to work. Now, I just have to get it to do the same with my Nest Cam motion notifications...


The lock screen on the fire can be overcome by enabling the Developer Options and turn 'Stay Awake' to on. Since I'm always plugged in, I'm not worrying about battery life. Here's a link that should help..


http://kindlefireforkid.com/how-to-enable-and-access-developer-options-on-amazon-fire-tablet-fire-hd-fire-hdx-and-kindle-fire-hdx-and-how-to-hide-developer-options-again/


As far as anything else goes that I found... you need the Ring app open in the background so that the triggers in Automateit can pick up the notification. If there is a better way of doing this without another 3rd party app, please let me know... 


For the DAKBoard link for the screensaver, make sure you use the private URL that's found under your account settings as the URL for the screen saver.

Great idea! Just a small improvement I can suggest is to tailor the notification trigger to only open when it has the Notification Text value of "Someone is at your {RING NAME}" as to avoid opening Ring for Neighborhood watch, etc.

This is great but I’m struggling to understand the second rule the fully app I can’t see that in actions

You want the second rule to reopen Fully after you have had a chance to view what is going on with your Ring unit.  So to setup the second rule, where it asks you the first time to choose an app to be opened by the notification... that way when Ring sends you a notification it triggers this rule.  Then under the "ACTION" tab, choose the Fully app here.  Then on the next tab where you give your rule a name, put a check mark in the Delayed Execution and change the option to one minute.   That way the second rule will not re open Fully for one minute.   

I followed all your directions and my ring app only opens to the list view.  Is there another setting I'm missing?

+2

Ring recently updated the app.  It ruined the setup.  You need to delete the app on your tablet and go then install the previous version of Ring. 

 thanks to CASEY HINKLE we have a fix .... go to https://m.apkpure.com/ring-always-home/com.ringapp   .... download the 2.0.43.5 apk .... uninstall the most recent ring,  install this downloaded APK.

Reminder to turn off auto updates on Google play https://gadgets.ndtv.com/apps/features/how-to-disable-or-enable-automatic-app-updates-on-android-1662649  and if you still have the amazon store on your table turn off autoupdates there too by going to  settings - apps & games - amazon application settings - appstore

@ginny  That solution did not work for me.  Is there something else I need to set?  I installed that APK, turned off updates and still the same Event list screen when the Automate action fires.  This is very frustrating!

Just out of curiosity, has anybody tried to use this same method with Tasker and the current version of the Ring app?  I had been using Tasker previously (which is an extremely powerful program, but very complicated), but it also "broke" when the new version of the Ring app was released.  I've been trying to modify my recipe so that it uses AutoNotifier to click on the Ring Notification instead of just switching to the app.  Unfortunately, it looks like it is about to show video each time, but then ultimately just goes to the app notification page.  Not quite sure why it's not working, but if anybody is a Tasker expert, I'd love to get your thoughts.

I just got this working with the latest ring app, tasker and autonotifier.  The setup is complicated and I don't even know how to explain it.  But I tested it and it loads ring straight to video, waits, then loads fully and closes the ring app.


The post below helped me set it up though.


http://forum.joaoapps.com/index.php?resources/press-a-button-on-a-notification-as-soon-as-you-receive-it.120/

+1

Thank you so much!!  This was extremely helpful and got it working for me too.  Now, even with the new Ring app, it will switch over to the video feed immediately from AT.  Were you successful in getting Tasker to close/kill the Ring app afterwards?  It doesn't seem to want to close my app and I wonder if it's because I'm running a non-rooted Fire.

I didn’t check that part. I was just happy to get it working. I’ll have to double check when I get home. 

Any chance you could explain how you set this up?  I can't seem to get mine working.  Thanks!

I got mine working, but RING forces updates and it automatically downloads the newest update even with Auto update off.

Nm, triple check the Auto update. Stupid thing would turn back on by itself. Finally got it.

ok figured it out: this is the solution:

@gavinCampbell figured it out but i didnt follow it the first time around

  1. Setup tasker to intercept the notification using Autonotification
  2. Follow this: http://forum.joaoapps.com/index.php?resources/press-a-button-on-a-notification-as-soon-as-you-receive-it.120/

You're basically simulating a button press 

Actually, I figured it out. But now the question is, any way to automate returning to Fully after a minute or two?