+12
Answered: Discussion Open

Solution: Fire, Ring Doorbell, Fully, and Action Tiles

Willis 7 months ago in Browsers Tablets Phones / Amazon Fire • updated by Jeremy Hazeltine 2 weeks ago 85

I have seen a lot of questions related to the Ring Doorbell and Kindle Fire...I figured out a workable solution:

Sideload the Google Play Store onto the Fire (I used the instructions at https://www.howtogeek.com/232726/how-to-install-the-google-play-store-on-your-amazon-fire-tablet/ )

Use the Play Store to install the Ring Doorbell app

Use the Play Store to install AutomateIt


Setup 2 rules in AutomateIt:

Rule 1:  On notification from Ring, run the Ring App

Rule 2:  On notification from Ring, run the Fully App with a 1 minute delay


AutomateIt will notify you that it needs permission to monitor notifications.  Allow that permission.


Start Fully, ring your doorbell, see your front porch, cheer, wait another half minute or so, and Fully restarts, conduct victory lap...and profit.


If you have motion detection turned on for the doorbell, this will also show your porch if something trips the motion sensor.

Fire
+1

Thank you so much for posting this. I do believe I got it.  I was having issues, but I was choosing the wrong option on Rule 2.  This was on a Samsung Tablet I have... tomorrow going to try on another tablet.... Thanks

Have you found a way to by pass the Fire Lock screen with your setup?  Thanks

As far as the lock screen goes, I used the developer options on the Fire to enable leaving the screen on when plugged in.  Then I run Fully with the dim: option enabled on the Fire in my bedroom and the dakboard.com app as the screen saver in the living room.  Set Fully to never sleep.

ahhh, I will go try that thanks.

Nice!  Looks very similiar to what I have running. 

Nice job, thank you for share.


My scenario is different, I have a camera on front door (connect to Blue Iris), Motion Sensor and my main screen of Fully show the camera in small size.



I want to show on full screen when I have motion sensor active and back to my main after few minutes. 


+1

If there is a notification with the motion sensor, you should be able to do something similiar.  AutomateIt can read notifications from any app.  AutomateIt may also be able to pick something else up from Blue Iris.

Thank you for your reply, but I do not want to open Blue Iris, I only want to see the camera on full screen like as you click on camera image on AT, any idea how can I do this?

I don't know how to do this, but there are some other forum abswers that talk about opening apps using url commands that might help you.

+2

I did have to make an adjustment to the AutomateIt rules when using the Dim: option on Fully.  The problem was that when the Ring app ran, it did not restore the brightness setting so the Ring app was barely visible.  


The fix is to add a third AutimateIt rule that triggers on the Ring notification and sets the Kindle brightness to a reasonable level.  Fully will turn the brightness back to Dim when the screen saver timeout hits.


Thank you for posting this, works perfectly when screen is unlocked on my Android devices, including Kindle Fires running Fully with AT.  The Kindle Fires are almost always unlocked, but the Android smartphone is almost always locked.

It looks like the paid version of AutomateIt might have the ability to perform screen unlocks.

The Pro (paid) verson is installed on my phone, and I've tried the unlock action without success. The FAQ seems to confirm my experience.

Simply amazing....Just what I have been looking for. Got it working relatively easy as well. However, your job is not complete....not until you find a way to get Arlo working. Then you will never hear a peep out of me. Just kidding....job well done!!!!!

Glad I was able to help.  I haven't played with an Arlo yet, so I'm afraid I can't be helpful there.

Hey that’s really good can I just check exactly what you mean by the second rule run the fully app? Cheers Rich

My second AutomateIt rule is to run the Fully app, but to delay the running of that rule by a minute.  When you setup a rule to run an app, there is a check box that allows you to delay-start an app.


And, just to be completely clear, run the Fully app on a Ring Notification...with the 1 minute delay.

This works great on my android tablet but I am having problems with my Fire Tablet. The Ring Camera comes on just fine (I reverted back to the older version) but it wont go back to Action tiles... it just keeps the video open. After some time, the Ring app will go back to the activity screen but it will not go to Action tiles. I have Automateit set up exactly as the android app. Any ideas? TIA!

Thank you so much, works perfectly!

I've started using the above method and it works great for when we are at home. The only issue I find now though is that if someone rings the doorbell my tablet automatically answers it and means I cannot answer it from my phone when not in the house. Anyone else have the same problems or just me? 

I haven't noticed that problem but I'll test it with my setup and let you know if it works differently for me.

I just tested mine...I rang the doorbell and could see the camera on 2 Kindle Fires and was able to open the app on my phone to see the camera.  I didn't try talking.

Thanks for reporting back. It might have just been that I had bad signal at the time but will try again. It's great having it automatically launch in Actiontiles while at home so you can see who's at the door but if it meant not doing being able to do it remotely i would have had to reconsider. Thanks again for checking

+1

Do we need to have the full version of the Automateit software.  I have tried this with skybell with the free version of the automateit. Mine did not work.  Any help would be great. 

I only have the free version of AutomateIt.  You shouldn't need any of the paid-only features.  I haven't played with a Skybell but I don't see why it would work any differently assuming that the Skybell app provides a notification when the doorbell rings.

On various devices I'm using both versions, Free and Pro, and it makes no difference for the Ring automation.


The Ring automation works only when the device is not in Sleep/Lock mode, for example on a device running Fully where the sleep option is disabled.


When running the automation on my Android Smartphone and the screen is locked, there is no way (AFAIK) to unlock the device other than manually, so it does not work as expected.

Thanks for the response. One thing I see is when I set up Automateit it did not ask for any permission to monitor notifications.  How do I do that after the fact.

Try manually running the rules in AutomateIt to see if you get prompted for notifications.  Otherwise, go into settings on your device, then apps, then AutomateIt, and see if you can change app permissions there.


You could always uninstall the app, then reinstall. When setting up the first rule that needs access to notifcations, Android asks for authorization.

I saw the notification and redoing the rule solved the problem.  Works great.  Thanks for the help.

Arn, I saw your previous post on this and I think we agree that the paid version of AutomateIt is not necessary for my solution to work on unlocked devices.  I'm afraid that security restrictions probably prevent anything from launching on a locked device. 


Assuming that Skybell pushes a notification to an unlocked device for a doorbell ring, there is no reason that AutomateIt shouldn't be able to perform the same way it does for Ring.

It’s asking me to add trigger ?

thanks 

 The "trigger" is a notification.  When you select "notification" there will be a button on the right side of the screen that lets you choose which app you want to trigger the action.  Select the Ring app.

is this correct ? When I hit perform action on rule one it goes to Ring app but when I Ring my Ring pro it won’t come on 

Thanks 

No, you need 2 rules triggered by a Ring notification...the trigger is a "Notification Trigger".  Start a new rule, scroll down to apps, select the "Notification Trigger" then select the magnifying glass over icons icon on the next screen amd select the Ring app.


Select Next, then select "Start Application Action", again select the magnifying glass over icons icon and select Ring.  Then hit next and save.


Repeat the above steps with 2 exceptions:  Start Fully instead of Nest and before saving, click the delay start button and delay for a minute or two.

Outstanding! Thanks!!! It’s working now I just need to figure out how to make video Vertical!! I’m hanging fire 10 vertical

Does ring app turn off in background?

+1

The app releases the doorbell after about 2 minutes.  I think there is an option in AutomateIt to close apps...you could do that using the same trigger and the same delay as reatarting Fully.

I had this setup working great and AutomateIt still brings up the Ring app when there is motion or the doorbell is rung, but it goes to the All Activity list and not the live view.  It looks like my Ring App has been updated as now I see a Motion Snooze button that I didn't notice before.  I get the same issue if I go an ring the doorbell and manually start the ring app on both my phone and kindle.  Does anyone else have this issue?  Is there a work around to go directly to the live view like it before?

interesting you say that - I’ve spent the last 30mins trying to figure out what was wrong with my setup as it’s only started doing this today. It looks like it’s an update to the app. Very annoying as it worked perfectly before!! 

Yup - me too - I was JUST GOING to post here and see what the problem is ... hmmnnn

I see what you mean.  Mine is doing the same thing. 

On my Fire 8 if I click on the Ring notification that pops up it does not take me to the camera view.  On my Note 8 when I click on the pop up notification it takes me to the camera view.  So for some reason it seems to have changed on the Fire's.

I'm not using a Kindle, but I am getting the same result on my Samsung tab.  Now it just takes me to the list of events and devices.  I noticed that if I click the notification, it will take me to live view.  I was reading up on if there are any apps that can auto click a notification, and it seems as though Tasker+AutoNotification can do it, but it looks to be a bit complicated.  Anyone have experience using these 2 apps?

Ok guys - thanks to CASEY HINKLE we have a fix .... go to https://m.apkpure.com/ring-always-home/com.ringapp   .... download the 2.0.43.5 apk .... uninstall the most recent ring,  install this downloaded APK.


Reminder to turn off auto updates on Google play https://gadgets.ndtv.com/apps/features/how-to-disable-or-enable-automatic-app-updates-on-android-1662649  and if you still have the amazon store on your table turn off autoupdates there too by going to  settings - apps & games - amazon application settings - appstore


This is coming from the smartthings facebook group again thanks Casey.

Yup, that is exactly what I did and it’s working. I posted the same solution in the Ring Facebook group yesterday. 

Is there a way to get to live view directly? I have tried all the above steps and correct rules.No success!

Sandy,

Did you rollback to Ring version 2.0.43.5 apk per Tom's instructions above?  I did that today and everything is running perfectly now.


If so, can you post a picture of your rules?

You are running version 2.0.52 of the ring software.  You need to follow Tom's instructions to download 2.0.43.5 when you go to the apkpure website he lists, you will be able to download multiple versions of the Ring software...make sure you get the right one.  Also delete your current version before you download reinstall 2.0.43.5 and make sure autoupdate is turned off in google play.

This is amazing and worked perfectly for me!!  One question, does anyone have any idea if there is an intents url and if so what it would be for the Ring app?  I want a tile to open the ring app.


Thanks!

Got it working! Yes!!! Thanks

Congrats!  Glad I could help.

Ring app updated itself automatically and it stopped working now.How do you fix that? I got it working again reinstalling the said process by Tom but now If I do stop auto updates in google play it will stop all updates on my google play account...Yes/No?

+1

Follow my instructions above - you need to keep both google play AND the Amazon store from doing updates (assuming you still have that - I do)

Is anyone getting any sound feedback from the Ring doorbell with this setup?  What I have noticed is when I leave out my front door, at about 11 seconds, I will hear what sounds like static feedback for 2 seconds.  Yesterday, twice, I left home to run an errand and my husband was still home and had Alexa playing music.  This time instead of static feedback, I heard the music that was playing in the house for about 2 seconds.  I have setup 3 tablets to switch from ActionTiles to the Ring view when motion is detected.  I am wondering if one of those tablets (or all 3?) are turning on the mic for just a second or two.  Any thoughts?  Thanks!

I've been getting this.  I don't think it is feedback as much as it is turning the tablet mic on when it goes to Liveview.

I am thinking that is it also.  I have 3 tablets inside with this setup.  Yesterday I turned all of them off... no static.  This morning, I had one tablet on and no static... but I had the husband go outside and when the tablet came up with the outside view, I tapped the green mic button.... sure enough, static.  So, later today I will mess with the other two tablets and see if one of them is somehow activating the mic....

No feedback on my end.  I have the sound turned all the way down on the Ring itself.  So when someone pushes the button it does not make a sound on there end, it only lights up.  Where are you hearing the sound from?

From the ring button itself. 

Do you have the Ring App running in Live View with the mic on all the time?  Thats they only way I can get feedback from the Ring.  I tested it using my phone so I was within 6 feet of the Ring.

+1

I keep getting a notification that I need to allow AutomateIt access to usage data (new Kindle Fire 8), but when I select the notification it just takes me to the general Settings page. Where do I go to give AutomateIt this access? I went to Apps>AutomateIt where you can see the current permissions, but I don't see where I can change them.


I have the two rules setup as mentioned above but when I ring my Skybell nothing happens.


Thanks

Does no one know how to give AutomateIt access to usage data? The app won't respond to any triggers.

Settings, sound & notifications, notification access, check the box for AutomateIt Pro.

Thanks. Turns out it was already checked, so now I don't know why AutomateIt doesn't respond to the trigger.

What version is your Ring App?

I'm using Skybell. I can manually execute the rule successfully, but for some reason AutomateIt doesn't pick up the notification from Skybell when ringing the doorbell. 

Maybe someone here can help, I have AutomateIt on my android phone and a older 20" SmartMonitor that is only as smart as Android 4.0.3.  On AutomateIt on that SmartMonitor, I do not get an option to add trigger "Notification Tirgger" which I see should be right below "Application Status Trigger".  Am I only seeing a subsection of available triggers and there is an option somewhere to list more?  I do not see this option anywhere on this device.  The smartphone does indeed have it in the list of available triggers. 

+1

BTW Ring app 1.9.29 has an option in the app for auto answer on motion or ring - and pops up VERY fast even on my slow slow tablet I'm using.  Sideload that APK and you can get rid of automateit task #1.  Got it from apkpure.

Where did you find v 1.9.29?  The oldest I'm seeing is 1.9.88 https://apkpure.com/ring-always-home/com.ringapp.

I don't see an option for auto answer in this version of the Ring app. 

Thanks for confirming.  Glad I checked here before deleting my current app and downgrading.  Anyone else know what Scott is talking about?  Has there ever been a version of the Ring app that had auto answer?

Has anyone found  solution for the audio feedback to stop?

I don't understand your comment "audio feedback"  can you explain more?

I am facing a similar issue like yours mentioned above Ginny .On Ring Motion detection my tablet mic turns on and i can hear the sounds from inside the house also some static sounds for a few seconds without me accepting/rejecting on my ring app.I don't agree with the workaround of having to put the volume down all the way on the ring all the way down to fix it . I hope I was able to explain.

What type of tablet are you using?  I am trying to isolate the problem, and I can not get it to consistently happen... urrrr

This works great on my android tablet but I am having problems with my Fire Tablet. The Ring Camera comes on just fine (I reverted back to the older version) but it wont go back to Action tiles... it just keeps the video open. After some time, the Ring app will go back to the activity screen but it will not go to Action tiles. I have Automateit set up exactly as the android app. Any ideas? TIA!

I am new to all these apps. Can someone please post step by step instructions? Thanks.

This seems to work on my fire 7, but very slow to initially respond, and it just opens the ring app. It doesnt open the video unless i navigate the ring app and open it. 

Thoughts?