0
Fixed

Video stream stops...

Tony 2 years ago in Media Tiles / Video Camera Feeds • updated by Terry (ActionTiles) (Co-Founder) 1 year ago 22

I have a video stream that stops updating after a while.. manual page refresh fixes.. using on Fully Kiosk on an Android Nexus 7 gen one tablet.. Video feed stops, and continues. A manual refresh fixes. Same Symptoms in Chrome on my mac. Any ideas on what might cause the feed to stop refreshing??

Waiting for Customer

Hi Tony,

Please provide more detail about the type of video camera / video stream:

  1. You use the word "refreshing", but only Media Tiles with set to "still image / gif / stop motion video" use a "refresh rate". Just want to confirm with you that this is a MPEG video stream, right?
  2. You say stops "after a while"... about how long in minutes. Is it always the same length of time?
  3. What type of camera, make, model?
  4. What URL are you using?
  5. Have you tried the URL/stream in a plain browser window without ActionTiles running? Does it exhibit the same problem after some period of time?

Thanks,

...Terry.

I came here to ask the same question. However, my issue is on Windows.


Platform: Windows 10

Video Source: Blue Iris setup as a video stream

Affected Browser: Chrome and Edge (have not tried Firefox)

Cameras: two (2) Hikvision

Time: can stop after 30 minutes or stay working for a couple hours

Fix: F5 to refresh


I see others have had the issue, but I don't see that they documented a fix. I was going to write a PowerShell script to reload the browser every 30 minutes, but wanted to ask here first.


Note: I have to try your #5


+1

1. You are correct.. refreshing was a poor and inaccurate choice of words! It's a live stream that stops loading.


2. The time it takes to stop varies..


3. Camera is a TrendNet TV-IP322WI


4. Using URL

http://192.168.86.32/streaming/channels/3/httppreview


5. I haven't left it running for an extended period of time in a plain browser.. am testing that now..


It's a live stream that stops loading.

When it stops loading, do you see a still frame? Error message? Some icon?

+1

I can also get the live stream to a browser from my Synology, to which the camera is attached.. this doesn't work as Media though for some reason.. I am also testing a JPG image that updates every 4 seconds to see if that works, as that would likely be sufficient..


http://MY_IP:5000/webapi/SurveillanceStation/videoStreaming.cgi?api=SYNO.SurveillanceStation.VideoStream&method=Stream&version=1&cameraId=2&format=hls&_sid=MY_SID



When it stops streaming on a browser on my mac, I see a still frame.. when it stops streaming on Fully Kiosk on the Android, I see nothing..


Actually stops streaming when using the Synology stream too.. though it doesn't appear to ever stop the feed to the Synology, unless the Synology just has a mechanism to handle it.. for now, I think I will use a still image refreshing on regular intervals as that works.. I would like to do it at 1s, though it doesn't seem to refresh faster than 4s..

I have the same issue. I have VLC transcoding a couple RTSP (another vote for integrated RTSP!!) streams from my cameras to an HTTP MJPEG stream. Works fine in ActionTiles for a period of time (30 mins, 1 hr, 2 hrs, random), then I get an empty tile with a 'broken image' type icon. Clicking 'Reload' on the tiles page fixes it and gets the streams started again. ActionTiles actually seems to have more of an issue than SmartTiles did. The old app I would have to refresh once or twice a day, ActionTiles is much more often. I had found that with SmartTiles, I setup a script on my PC that would manually quit and restart the VLC streams, and it would seem to kick them back on. However with ActionTiles it isn't working, I have to manually refresh the Panel to get them working again. 


Now i'm not entirely sure this is an ActionTiles issue, it could be the stream hiccuping and causing the issue or something in the first place, but since a 'Reload' or refresh fixes it, i'm wondering if we can program a manual 'Reload' into the app as a basic workaround? I.e. just force it to do a page reload on a configured schedule, like every 30 minutes? 

Researching

Thanks for such a detailed report, CM... 


We may be in touch with you directly to dig further.


As for the "auto-reload" suggestion; if it is definitely a consistently helpful workaround and isn't required too frequently, then we are open to the idea.


Have you tried defining the Media Tile as a "still image"... in other words, using the Refresh option already available in ActionTiles?

Hi Terry,

Experiencing the same symptoms on my IOS iPhone Safari browser using the Actiontiles page. 


MJPEG streams from 1) a direct connection to a local  Foscam Ih the P camera and 2) to the same camera via a Blueiris gateway.


Clearing the cache through the settings panel restores the image. Refreshing does not.


The problem does not manifest when I load/refresh the URL/stream in a plain IOS Safari window without ActionTiles.


Hope this helps.


Thanks, Ken



We have some video streaming tweaks going to Beta this afternoon. If they don't make things any worse, then this will be promoted to production soon so we will find out if they improve your experience.

Hi Terry, any info about this, my camera freezes every 2 or 3 hours. 
Thanks

Fix in BETA

We have a couple of Media Tile / Video streaming tweaks staged in Beta that we are hopeful will significantly improve or fix this particular or similar problem(s).


So far it is inconclusive because the issue only occurs in difficult to reproduce situations... So we will probably expedite this to production soon.

Hi Terry, 

Thanks for following-up! 

Let me know if you need me to test the tweaks with my streaming configurations. 


Having similar issue with hikvision cameras.  Recently tried to change to streaming URL and it works in the preview the first time I configure it, then if I close the renter the config screen it doesn't show the video in preview.  If I refresh the browser and renter the config it's there again.


I had it working using the synology NAS links however my cameras only support h.264 on the main channel where I get full resolution.  If I change to a sub channel I lose resolution, not an option.

+1

We completed out Beta testing for some Media streaming issues. This fix will be deployed in the next couple of days in release 6.2.2. Please let us know if your issue remains after the updates.

Hi Terry,


The update killed my Blue Iris feed.


I determined that the feed no longer works under v6.2.2 unless I replace my dyndns.org address in the URL with the local IP address for my Blue Iris server.


Both the dyndns and local addresses worked in the previous build.


Let me know if you need any additional information. Examples of the URL are listed below.


Thanks, Ken


Examples:


DYNDNS URL:

http://######.dyndns.org:8072/mjpg/garage/video.mjpeg

LOCAL ADDRESS:

http://192.168.1.157:8072/mjpg/garage/video.mjpeg



Hi Ken,


How many video tiles do you have on one panel?

Thanks

Hi Alex,

The number of feeds vary.

 I currently have 1 active video panel.



Thanks for the report, Ken.


I sent you a PM, but let's also see if others experience this.

+1

Hi Terry,

The feed just started to work and is now able to resolve the Dyndns.org address.

I'll continue to monitor and post any changes.

Thanks, Ken


Commenting disabled