+3
Discuss & Vote

Fire HD 8 - cameras not working with recent OS/App update

gpaitai 10 months ago in Browsers Tablets Phones / Amazon Fire updated by Lisa 4 months ago 23

Yesterday I arrived home after work to find my tablet with a black screen. My assumption is an auto-update had turned it off after updating. I do have it sitting in the powered stand so it was fully charged.

Anyways, I have four cameras via TinyCam Pro web server that I can view within ActionTiles but only show two on my main view. These have worked perfectly for years until yesterday. I can view my cameras ok via Safari on my Mac & iPhone but not the Fire HD 8 tablet. Note the TinyCam web server is using http not https so I'm wondering if Amazon have decided to force this security in their update.

Has anyone else had encountered the same? Any suggestions or ideas welcome.

Fire

Answer

Answer

All of the issues serving video streams and images are due to browsers and operating systems enforcing Mixed Content policies.

Mixed content refers to a situation that arises when a secure (HTTPS) webpage contains elements, such as video streams or images that are loaded using an insecure (HTTP) connection.

More and more web browsers enforce strict security policies to protect users' data and privacy. When a secure webpage includes insecure content, it poses a risk and compromises the integrity and security of the entire webpage.

To mitigate this risk, modern browsers typically block mixed content by default. They either prevent the insecure content from loading or display a warning to the user. To maintain a secure browsing experience, it's important to ensure that all elements on a secure webpage are loaded using secure (HTTPS) connections. This can be achieved by updating the resource URLs to use HTTPS or by hosting the resources on secure servers.

ActionTiles does not host or process your local video streams and images. It is impossible for ActionTiles to upgrade connections to HTTPS.

ActionTiles cannot affect the browser and operating system and relies on them to display the content. There's absolutely nothing that ActionTiles can do to make the browser display content that the browser does not allow.

The Mixed Content limitation that is now imposed by modern browsers is not an issue that's unique to ActionTiles. Every web page and Progressive Web App is affected by this.

There are two ways to resolve this issue:

  • Serve content over HTTPS.
  • Configure the browser to allow mixed content. There are several issues with this option, since some browsers do not have this configuration or ignore it.
+1

Well after resetting the tablet to factory defaults twice and reinstalling from backup using the automatic option, the result was the same, no cameras would show in ActionTiles on the tablet only (ActionTiles via Safari on both my Mac and iPhone had no problems previewing the cameras).

I tried resetting one last time but this time choosing the manual setup option - lo and behold, after downloading TinyCam Pro app and inputting all my camera settings from scratch and turning it's web server on, then downloading the ActionTiles app and logging in, the cameras suddenly work once again as it did before. Go figure!?! Hopefully this helps someone else.

To get your cameras working again, you just setup again from scratch and it worked? Anything in particular you had to do?

Nothing special, I reset my tablet to factory default and installed the ActionTiles and TinyCam Pro apps. Entered all the same settings from scratch and it just worked. Something obviously corrupted the tablet which then got saved to my automatic backups. Resetting your tablet to factory default and manually inputting your settings was the fix for me.

Alex, I was unable to get this solution to work within the Kiosk browser. Is your suggestion to just use the ActionTiles mobile app? 

ActionTiles mobile app is based on the Fully Kiosk browser. Make sure you are running the latest version of Fully. They have done some work with regards to Mixed Content. If the problem remains, you may need to contact Fully support and provide details about your Android device and version. Ask for assistance to resolve a general Mixed Content issue as it is not specific to ActionTiles.

You may try the ActionTiles mobile app, in case it will work to display your videos, it doesn't heart to try. The current version of app is available here:

https://support.actiontiles.com/knowledge-bases/8/articles/10267-actiontiles-moble-app

The app will be updated in the coming days to be in sync with the current version of Fully.

Hi, 


Having the same issue at my side with camera snapshots from Reolink NVR (http snapshots). It used to wotk and now nothing work - tried the actiontiles app and fully kiosk on the fire 10. 


Is there anything that I can do? 


Thank you

Are you using the latest version of Fully? Did you try to turn on the "Allow Mixed Content" option?

I am using the latest version. 


Maybe they removed this option because I searched it in the settings using the search option and nothing was found - maybe this is the problem... 




+1

Reolink Solution (At least for me)

This solution resolved the following for me:

  1. Images appearing via https vs. http
  2. Images refresh every X seconds.

Note: I have Kiosk Version 6.1.29h for Fire tablets. I couldn’t find the setting to ignore SSL errors in the newer versions.

  1. Make sure to enable your NVR to allow HTTPS (see source link below)
  2. In ActionTiles site, update all media to link to HTTPS (under “My Media”, edit each one, select “This Media is a Still Image or GIF”, update link to have the S after HTTP, AND add “&width=640&height=480” to end of the link, put in the refresh rate, select update). See notes for more info on this portion.
  3. In ActionTiles Version 6.1.29h, select Ignore SSL under “Advanced Web Settings” (swipe right to get to “settings” within ActionTiles app)
  4. Run App.

Notes:
For the longest time, I was using the following link (except using HTTP before):

https://[IP-ADDRESS]/cgi-bin/api.cgi?cmd=Snap&channel=7&rs=wuuPhkmUCeI9WG7C&user=[USER]&password=[PASSWORD]

I added the "&width=640&height=480" to the end and now I get refreshes without refreshing the whole app/site. Makes it a JPEG?

https://[IP-ADDRESS]/cgi-bin/api.cgi?cmd=Snap&channel=7&rs=wuuPhkmUCeI9WG7C&user=[USER]&password=[PASSWORD]&width=640&height=480

Replace the brackets with your information. Hopefully that helps.

Source: https://support.reolink.com/hc/en-us/articles/360007011233-How-to-Capture-Live-JPEG-Image-of-Reolink-Cameras-via-Web-Browsers/

Live Stream:

One more thing to note, if you want a live stream, you can do so using

https://rtsp.me/ for one camera for free.You would have to do port forwarding and use your external IP address.  You would provide it your rtsp link and it will give you a link that you put in ActionTiles (hit play, and there you go).

rtsp://[USER]:[PASSWORD]@[EXTERNAL IP]:554/h264Preview_08_main  (08 is one of my camera)

Spits out  https://rtsp.me/embed/blahblah/ which you put in action tiles as an embedded link. Source for creating link: https://www.ispyconnect.com/camera/reolink

+2

I am having the same problem.  I have been using streams from tiny cams pro for a couple years and all of a sudden it STOPPED working.  I have confirmed tiny cam pro is working (Im able to copy and paste the URL from my action tiles "MY MEDIA" and paste it in the browser and I can see the camera feed fine-but when in actions tiles it says " Enter valid URL to preview video stream)  I have uninstalled and reinstalled, but still no luck.  I have tried action tiles app, using fully on my tablet and from google chrome on a pc same result.  Any hints?  I have been trying all day :(

+3

I've got the same problem after the recent update, and I can only conclude that something has changed in Actiontiles to break this. All of my cameras were working fine, but now show the same invalid url as other users. This happens on my Fire Tablet as well as running Actiontiles in Chrome on Windows 11. If I copy the URLs being used from Actiontiles into Chrome then they work fine, so it isn't an issue with Chrome. This needs to be looked at and fixed. 

+1

Same issue.  I have tried all of the setting adjustments in Chrome, Full Kiosk, and the Actiontiles app, but I still cannot see cameras in Actiontiles.  Like others, I can paste the link into Chrome and pull up the stream.  My issues started over a month ago, though, and I've been fighting to figure out the solution ever since.

Running Fire HD 10, OS 7.3.2.7

I did try the OP idea of resetting the tablet to factory default and reprograming tiny cam (not from a backup) and it still doesnt work.   

Answer

All of the issues serving video streams and images are due to browsers and operating systems enforcing Mixed Content policies.

Mixed content refers to a situation that arises when a secure (HTTPS) webpage contains elements, such as video streams or images that are loaded using an insecure (HTTP) connection.

More and more web browsers enforce strict security policies to protect users' data and privacy. When a secure webpage includes insecure content, it poses a risk and compromises the integrity and security of the entire webpage.

To mitigate this risk, modern browsers typically block mixed content by default. They either prevent the insecure content from loading or display a warning to the user. To maintain a secure browsing experience, it's important to ensure that all elements on a secure webpage are loaded using secure (HTTPS) connections. This can be achieved by updating the resource URLs to use HTTPS or by hosting the resources on secure servers.

ActionTiles does not host or process your local video streams and images. It is impossible for ActionTiles to upgrade connections to HTTPS.

ActionTiles cannot affect the browser and operating system and relies on them to display the content. There's absolutely nothing that ActionTiles can do to make the browser display content that the browser does not allow.

The Mixed Content limitation that is now imposed by modern browsers is not an issue that's unique to ActionTiles. Every web page and Progressive Web App is affected by this.

There are two ways to resolve this issue:

  • Serve content over HTTPS.
  • Configure the browser to allow mixed content. There are several issues with this option, since some browsers do not have this configuration or ignore it.

The only way I could get http cameras working was by using Actiontiles in the Fully Kiosk Browser and enabling allow self signed certificates. The issue is that using it this way is slower than the app. Is there anyway to have this option in the app if it is based on Fully Kiosk?

I'm waiting for more information from the developer.

When you paste a video stream or image URL into the browser, it does not encounter a Mixed Content situation, because there's only one element loaded over HTTP and there's no HTTPS security police conflict.


If you are able to load the video stream or image in your browser, it does not imply that ActionTiles will be able to display it. ActionTiles will only be able to display it if your browser does not enforce the Mixed Content security policy.

Thanks for replying!  I am using tiny cam pro & fully browser. I have Fully selected to "‘Always Allow Mixed Content" and for tiny cam pro under manage camera, I did select the "Use HTTPs" option. Would the string for the media tile change with these options?? Currently It was set to: http://192.168.XX.XX:8083//axis-cgi/mjpg/video.cgi?camera=1user=USER&pwd=PASSWORD

Do I have to change the URL to HTTPS & the does port change (or stay the same as the web server?)

I was not aware that Tiny Cam offers the HTTPS option. That's great news!

The HTTPS port is usually 883. You will have the update the URL.

did you get this working? I tried and they don’t appear within actiontiles. Is it just a matter of changing the string to https because that doesn’t work for me unfortunately 

It is not sufficient to just change the URL to HTTPS. The camera or the media server must be able to support secure HTTPS connections. To verify whether secure connection is properly configured, open the HTTPS URL in another browser.

I didnt, I ended up giving up on this.  I just use tiny cam pro view on my mounted tablet.