0
Fixed

SHM status not updating (probably due to SmartApp Mode Filter usage)

Nathan Davis 3 years ago in Panels (dashboards) / Special Tiles updated by Terry (ActionTiles) (Co-Founder) 2 years ago 10

Hello. I noticed this morning that ActionTiles is not updating my SHM status. If I disarm or arm from the SmartThings app, ActionTiles does not reflect the change. I can still control the SHM from ActionTiles and it works fine, but I thought ActionTiles automatically reflected the changes from the smartapp, at least I think it was since before this morning. Thanks.

Answers

Answer
Doc / UI Unclear

Thanks again for all that experimentation and research, Nathan!

If I set any options in "Set for specific mode(s)" in the smartapp that is what causes the SHM to read incorrectly.

Unfortunately the "Set for specific mode(s)" option on the SmartApp preference page (and all the automatic mode filtering functionality that option affects) is entirely outside of our control.


The "mode filter" option is automatically appended to any "basic" SmartApp (and we kept our SmartApp "basic" to maximize its efficiency and ensure it was "Works with SmartThings"™ approvable). We have no control over how it works (or how its use may adversely affect ActionTiles!).


We will look into revising the SmartApp to try to remove this option in the future, but in the meantime, all we can say is: Do not use the "Set for specific mode(s)" option of the "ActionTiles V6 (Connect)" SmartApp!


We will post a Knowledge Base article in this regard.


Thank-you,

...Terry.

PINNED

I took it a step further and removed the ActionTiles app from SmartThings and then re-authorized it through ActionTiles. I had to recheck all of my devices, but my panel was still saved and the SHM is now working again! Thanks for the idea!

PINNED
Waiting for Customer

Thanks for reporting this Nathan!


I'm not sure how many ActionTiles customers are experiencing the problem, but I believe this is likely a side-effect of yesterday's Smart Home Monitor outage reported by SmartThings: http://status.smartthings.com/incidents/63gtvzwcq5gt


Luckily, I believe there is an easy fix!

Take one of these two steps please:

  • Go into the SmartThings mobile App, open Automations / SmartApps / "ActionTiles V6 Connect", and just tap "Done".
  • or; In ActionTiles, go into My Locations / Location / Menu - Location Settings / Authorize Things. Select your SmartThings Location from the drop-down box, and tap "Authorize".

Please let me know if it fixes the issue. If not, try both options and check again.


Thank-you!

...Terry.

PINNED
Waiting for Customer

Thanks for reporting this Nathan!


I'm not sure how many ActionTiles customers are experiencing the problem, but I believe this is likely a side-effect of yesterday's Smart Home Monitor outage reported by SmartThings: http://status.smartthings.com/incidents/63gtvzwcq5gt


Luckily, I believe there is an easy fix!

Take one of these two steps please:

  • Go into the SmartThings mobile App, open Automations / SmartApps / "ActionTiles V6 Connect", and just tap "Done".
  • or; In ActionTiles, go into My Locations / Location / Menu - Location Settings / Authorize Things. Select your SmartThings Location from the drop-down box, and tap "Authorize".

Please let me know if it fixes the issue. If not, try both options and check again.


Thank-you!

...Terry.

Hi. I just tried both options, but it is still out of sync. I believe you are correct that it is related to their SHM problem yesterday, because before that it was reflecting the changes immediately.

Discuss & Vote

Darn! The first step fixed it right away for me... 😖


Let's see if others confirm that they are experiencing the same issue, please.

PINNED

I took it a step further and removed the ActionTiles app from SmartThings and then re-authorized it through ActionTiles. I had to recheck all of my devices, but my panel was still saved and the SHM is now working again! Thanks for the idea!

Workaround: Please Confirm

Thanks for the extra effort, Nathan!


Glad it is working ... I hope not too many people have this issue. Guess we will know soon!

Well, I hate to say that that was a temporary fix. When my night routine kicked in and auto set SHM to arm/stay, ActionTiles did not reflect the change and it still shows disarmed. Not sure what else to try. Maybe something is still wonky on SmartThings' end.

+1

I think I may have found the problem and it appears to be a bug in the ActionTiles app in SmartThings. If I set any options in "Set for specific mode(s)" in the smartapp that is what causes the SHM to read incorrectly. If I then uncheck all the modes and save the changes the problem with SHM is still there and if I go back into the smartapp the modes are still checked as if I never unchecked them. The only way to fix the problem is to remove the smartapp again and reauthorize. Hope this makes sense.

Answer
Doc / UI Unclear

Thanks again for all that experimentation and research, Nathan!

If I set any options in "Set for specific mode(s)" in the smartapp that is what causes the SHM to read incorrectly.

Unfortunately the "Set for specific mode(s)" option on the SmartApp preference page (and all the automatic mode filtering functionality that option affects) is entirely outside of our control.


The "mode filter" option is automatically appended to any "basic" SmartApp (and we kept our SmartApp "basic" to maximize its efficiency and ensure it was "Works with SmartThings"™ approvable). We have no control over how it works (or how its use may adversely affect ActionTiles!).


We will look into revising the SmartApp to try to remove this option in the future, but in the meantime, all we can say is: Do not use the "Set for specific mode(s)" option of the "ActionTiles V6 (Connect)" SmartApp!


We will post a Knowledge Base article in this regard.


Thank-you,

...Terry.

+1

Understood. I used the option merely out of curiosity. I know there is really no point in using it so I won't use it anymore.

Commenting disabled