0
Fixed

Shared Panels - Interactive Mode not executing routines

Josh Barnhardt 2 years ago in Panels (dashboards) / Sharing • updated by Terry (ActionTiles) (Co-Founder) 2 years ago 15

Sharing a panel with two simple routine tiles.
I have it set to interactive mode for secondary user.
Using this panel with the primary account, click the routine tile - the routine executes.
Using this panel with the secondary account, click the routine tile - nothing executes.


Am I missing something? Or is this a bug?

Waiting for Customer

Hi Josh...


For a moment this didn't work for me, but a moment later ... it's working...


  • Sharing permissions can take a minute to two (hopefully not much longer!) to propagate through the system.
  • Could you try again please?
  • Also please verify that a few other interactive shared Tiles are working.

Thank-you!

...Terry.

+1

Thanks Terry.


Here is what I did:

I added a generic switch to the existing panel. Showed up as a question mark, would not let me interact.

Changed the sharing permissions to view only. Then back to interactive.

Still no Luck.


I created a new panel and shared it with that same switch. This worked.

I went back and unshared previous panel entirely. Reshared it, now it works.


No idea why, but problem is solved.


Researching

You may have encountered a "race condition" or some glitch in Panel permission propagation that hasn't been observed or reported before.


This will be important to fix if it recurs and we can find the pattern; so thanks for all those details.


Enjoy ActionTiles ... and sharing!

...Terry.

I spoke too soon. Sorry.


This is only working for the switch. (The switch was stuck unable to do anything and what I did fixed that for sure.)


The routines I have are only working with the primary account.


I can share the panel out to you if you'd like...

Yes... Please share to Terry@ActionTiles.com

Okay shared.


You will notice when you click on a routine (goodbye for example) nothing will say the routine was executed at the top of the page like I see as a behavior when i do so from my main account.


Switch works fine from this shared panel.

Thank-you...


Please refrain from editing / changing either Panel or Account while we investigate.


...Terry.

+1
Confirmed Bug

OK... I am able to reproduce the problem. Yay!


We'll work on finding the root cause and keep this Topic updated.


Thanks for the important observation report, Josh.

...Terry.

Do you wish me to leave the panel shared?

+1

In order to help confirm our fix (we think this bug is pretty urgent) it would be helpful, though not essential, if parts of your configuration remained stable related to the issue:


  • Feel free to reduce the Shared Panel to just a harmless Routine Tile so that we can "click it" to validate our fix.
  • Please feel free to create other Panels in your primary Account.
  • Please don't add/attach any SmartThings Locations to your Buddy Account (i.e., the secondary Account to which you are sharing).

Super appreciate it,

...Terry.

+1

Okay I created a pretty simple test situation.


The panel I have shared with you now has a test switch you can turn on or off at will - this works.


There is now a mundane harmless routine that will only turn that switch on - this currently does not work from buddy accounts, but works from the main account. You can see if it works not only by the status of the switch turning to on, but also by the routine execution status pop up.

Fixed: Please Verify

Hi Josh, We have pushed a "hotfix":


  1. From the owner account, please make a small "random change" to the test Shared panel "Test for Terry" to force it to refresh (e.g., add a Tile and remove it again).
  2. Test the shared panel from any Buddy Account and see if the Individual Routine Tile now functions.
  3. Alert me, so I can also test that Panel & Tile since I am Buddy of it.

Thank-you,

...Terry.

Commenting disabled