Halo+ smoke detector not working in ActionTiles

miodek81 4 years ago in Things & Capabilities updated by Terry (ActionTiles) (Co-Founder) 4 years ago 26

I was wondering if you are planning on supporting halo+ smoke alarms with action tiles?
Right now i have them added in ST but it is not being recognized by action tiles.

Thank you.


Confirmed Bug

Thanks for the info, Jorge. That is helpful.

We have found a root-cause  Bug  for Halo still not working. This Topic will be kept updated with progress.

Thank-you for the diagnostic assistance and your patience,

...Terry (& Alex)


As frequently is the case, we suspect the problem is this: Some Devices are missing from the Authorize Things (Add Location) screen?

Unfortunately, I can't find the Device Type Handler source code in the SmartThings public GitHub library, so I can't verify this, but we will escalate to our SmartThings back-channels.

As a verification, my First Alert Smoke and CO detector works great with ActionTiles.

Yup — So do mine!

I'm sure this is the usual small overlooked specification in the SmartThings Certified Device Type Handler.

The Halo is quite a powerful Thing with many features, but at least we want to support it as a regular smoke & CO detector.

This Topic will be updated as we hear back from SmartThings.

miodek81 via email 4 years ago

I was wondering if there has been any update from SmartThing yet ?

No... Their response time can vary on stuff like this. They used to suggest using a Support Ticket and then changed their minds on that idea.

I'm confident it will be fixed, but it probably won't be very quickly. 🙏

Hi, I am interested too, this HALO product really rocks, sold out in all the stores near the border and I've got 4 of them. Now, really hoping to have it displayed in ActionTiles. Should I contact Smartthings to speed things up?

SmartThings Issue

To be fully honest, we have received mixed messages from SmartThings regarding whether or not issues like this should be run through their front-line Customer Support. We were last asked to not recommend that our Customers escalate to SmartThings Support if we are already communicating the issue through the back-channel.

Thanks, Vadim.

I just sent a reminder to SmartThings. (Based on the Device Editor in IDE, it looks like the published DTH still does not have Capability "Sensor"). I'm sure they will get to it eventually.

SmartThings sent an update: Development changes for this are in progress.

Thanks for updates, Terry, I decided not to wait and just purchase AT licence anyways, great product!

Fixed: Please Comment

Thank-you Vadim!

Some possible good news: We pushed a SmartApp update yesterday with v6.4 of ActionTiles, and...

  • Can you please try the Add Location function again now (or My Locations / <location> / menu-Settings-Authorize Things)?
  • Your Halo should appear (we hope!) in one of the two new lists of "Things" available to select.

Please let me know if it works!!!



I could add it via authorized option but it still not showing in add things on Panel

Waiting for Customer

Could you please provide a screen shot or even just the text of the Device Instance "State" Attribute values details, per this KB? 

It still applies to this situation, I think, despite the title... 

Question mark "?" shown on Virtual Switch or other connected Thing Tile

The same for me, i can see HALOs when i Add Location, but after it doesn't show them on Add Thing. Also, thanks for information on update, i couldn't figure out why my cameras stopped displaying. Now only WAN IP works, not local ip

I need to see these values from your Halo Device detail page in the SmartThings IDE/API web page please:

Is there any place to look at change log for new release?

Look under About inside the app, there's a link.

Sorry... It's more complicated than that. We need the information from the SmartThings IDE Web page.

Please start with these instructions to get logged into the right page... 


  • Please try the Synchronize Location function inside the ActionTiles App under My Locations / (location) / menu-Settings.
  • Then check out Location details for the Halo Device under My Location / (location).
  • And try adding a Smoke Tile again.

I'm sending this over to a Private Ticket so we can dig more deeply.

My Values in IDE is the same as Vadim.:

I tried Synchronize sometimes already, but still the same.

The Halo is not being showing in the Location inside the ActionTiles.

Confirmed Bug

Thanks for the info, Jorge. That is helpful.

We have found a root-cause  Bug  for Halo still not working. This Topic will be kept updated with progress.

Thank-you for the diagnostic assistance and your patience,

...Terry (& Alex)

Commenting disabled