0
Fixed

Color control not working LIGHTIFY A19 RGBW / Flex RGBW

kerednai 9 months ago in Things & Capabilities • updated by Alex (ActionTiles) (Co-Founder) 8 months ago 6

Hi,

I have added 3 OSRAM LIGHTIFY A19 RGBW bulbs which I get a light level adjustment slider for in Action Tiles, but not the color changer.

I have also added 1 OSRAM LIGHTIFY Flex RGBW which was working just 10 mins ago, but now appears to be in the same state. All I did between this working and not working was to review what was set in the SmartThings device info.

From the description this seems to similar to this fixed bug. Has this fix been rolled out yet?


Here is the info of  the devices..

OSRAM LIGHTIFY A19 RGBW:

Data:

  • model: LIGHTIFY A19 RGBW
  • application: 01
  • manufacturer: OSRAM
  • endpointId: 03

Current State:

OSRAM LIGHTIFY Flex RGBW

Data:

  • model: LIGHTIFY Flex RGBW
  • application: 01
  • manufacturer: OSRAM
  • endpointId: 03

Current State:



Thanks for your help.

Ian


Answers

+1
Answer
Confirmed Bug

Great! Well... I guess there's a pretty simple workaround until we fix this little bug. 🐛 


Thanks!

... Terry.

PINNED
Waiting for Customer

Howdy,


Yes... The bug you linked has been deployed and I think we received verifications that it was fixed; but ... I have a wild hunch worth checking...


  • When the bug existed, ActionTiles required a value for Attribute "color" in order to offer color control.
  • We patched so that ActionTiles will also provide color control with only (but both) Attributes "hue" and "saturation" set.
  • Thank-you for providing the Current States values for all the Attributes - Super helpful!
  • My wild hunch? Notice that Hue and/or Saturation have value of 0 (zero).
    • Please use the SmartThings App to change the colors of the bulbs so that Hue and Saturation are both non-zero. Practically any color will do.
    • Use the ActionTiles / My Locations / (location) / SYNCHRONIZE feature and see if the Tiles work properly.
    • If that didn't work, then use the AUTHORIZE function to remove and then re-authorize the Bulbs. You might also have to remove and re-add the Tiles.

If the above steps work, then we have a simple but obvious typo ... i.e., equating 0 to be null / non-existent and thus assuming Color Control is not available on those Things. Let's find out!


Thank-you,

...Terry.

PINNED
Waiting for Customer

Howdy,


Yes... The bug you linked has been deployed and I think we received verifications that it was fixed; but ... I have a wild hunch worth checking...


  • When the bug existed, ActionTiles required a value for Attribute "color" in order to offer color control.
  • We patched so that ActionTiles will also provide color control with only (but both) Attributes "hue" and "saturation" set.
  • Thank-you for providing the Current States values for all the Attributes - Super helpful!
  • My wild hunch? Notice that Hue and/or Saturation have value of 0 (zero).
    • Please use the SmartThings App to change the colors of the bulbs so that Hue and Saturation are both non-zero. Practically any color will do.
    • Use the ActionTiles / My Locations / (location) / SYNCHRONIZE feature and see if the Tiles work properly.
    • If that didn't work, then use the AUTHORIZE function to remove and then re-authorize the Bulbs. You might also have to remove and re-add the Tiles.

If the above steps work, then we have a simple but obvious typo ... i.e., equating 0 to be null / non-existent and thus assuming Color Control is not available on those Things. Let's find out!


Thank-you,

...Terry.

+1

Hi Terry. Thanks for the quick reply. After changing the color of the bulbs so the hue and saturation was not zero the color picker started working in Action Tiles. I didn't have to synchronize or authorize to get it to work. So it does suggest that you are equating 0 to be null.

+1
Answer
Confirmed Bug

Great! Well... I guess there's a pretty simple workaround until we fix this little bug. 🐛 


Thanks!

... Terry.

Commenting disabled