+3
Answered: Discussion Open

Help: Using Dakboard as Fully screensaver?

rlburkes 2 years ago in Browsers Tablets Phones / Android updated by Terry (ActionTiles) (Co-Founder) 2 months ago 23

I’m having issues with Dakboard and the screensaver. It doesn’t seem to appropriately size the content, so it’s pretty poorly laid out (most content is offscreen) it looks fine in other browsers on the fire so it seems to be related to fully. I was wondering how you had Dak configured assuming it looked good for you?

Android Fire

Answers

+2
Answer
Answered: Discussion Open

I found out my issue, Fully has an option under  Settings > Web Zoom and Scaling  for “Use Wide Viewport” which was on . Turning that off fixed my issue with Dak as the screensaver.

PINNED

Just figured out how to get what I wanted in terms of screensaver and dimming. Posting in case anyone else is following along.

Turns out there is some non-intuitive behavior and coupling between Fully and FireOS. Here is what i wanted:

1. After Fully screensaver timer expires, start Dakboard at full brightness.

2. After a certain amount of time, dim the Dakboard screen but keep it "slightly" visible - not a black screen.

3. Return to actiontiles on touch.

The dimming of Dakboard was the issue. Here is how I solved it:

1. In FireOS, Developer Options -> Stay Awake : Turn this ON.

2. In FireOS, Display -> Advanced -> Sleep : Select the TOTAL amount of time from inactivity to dimming.

3. In Fully, Screensaver (PLUS) -> Screensaver Timer : Set to seconds of inactivity to Dakboard starting. Should be less than time set in step 2.

4. In Fully, Screensaver (PLUS) -> Screensaver Wallpaper URL : Set to your personal Dakboard screen URL.

5. In Fully, Device Management -> Keep Screen On : Turn this OFF. This was the non-intuitive part for me.

Now, after the time in step 3 Dakboard starts, and at the time set in step 2 the display dims.  By the way - the display will dim whether you are in the screensaver or not after the sleep timer in FireOS expires.

+2
Answer
Answered: Discussion Open

I found out my issue, Fully has an option under  Settings > Web Zoom and Scaling  for “Use Wide Viewport” which was on . Turning that off fixed my issue with Dak as the screensaver.

How do you have this set up as a screensaver?  I can't find a app that will launch this. 

+1

If you're using Android, Fully Kiosk Browser can launch it and it's pretty incredible for using with AT:


http://www.ozerov.de/fully-kiosk-browser/


I love the fact it can use the tablet's camera to wake the screen when you walk up to it.


In the app settings it's under the device management section, just use your Dakboard private URL found in https://dakboard.com/options/account .

What Screensaver are you using?

I’m using a Dakboard dashboard. 

I was hoping to use dakboard as a screensaver, so when I interact (touch) the tablet, dakboard would disappear and land on actiontiles.  I tried using fully but can’t seem to find a working solution.   I thought about just using chrome and living with the browser tabs and the address bar, but it’s not visually appealing.  What do others do to go from Dakboard to AT?

+1

I just set this up after seeing this post.  Have you tried this:


-copy "private url" from dakboard account settings

-go to fully under settings, device management, screensaver url, paste it there

-then set your screensaver timer (above screensaver url)


This should work as long as you don't have motion detection enabled.  If you do, dakboard disappears as soon as you pass by.

I am using it exactly like you've described. I have Dakboard set as the screen saver, and do not use the motion detection, therefore it requires me to tap the screen (which is always on, never sleeps) to reveal my panel.

I am using a older tablet and fully kiosk is not compatible. So,I am trying Kiosk Browser which does work ok but for some reason does not like some icons in AT (scenes and Sonos) and can logout of AT after longer periods.  I have adjusted settings and has not solved the problem.  The screensaver I am using now is Photo Slides Lite.  It is ok and shows the time like Dak but not temperature which this time of year in WI it is helpful to know its -4.

When I set up Dakboard dashboard URL as the screensaver in Fully, it comes up in the Fully browser, but touching the screen doesn't bring it back to the Fully Start URL (which is an ActionTIles panel). Is there some other setting I am missing?

I found out my problem - I had the Dakboard URL in the wrong location. I had it in the "Select Screensaver App" instead of "Screensaver Wallpaper URL." Once I entered it in the correct place, it works!

I thought I had Fully and Dakboard set up to show the Dakboard screensaver (after the Screensaver Timer time) but then sometime later the Dakboard screensaver would dim. I seem to have lost the ability to have the screensaver dim. Any suggestions? This was exaactly the behavior I wanted.

Actually, what would be perfect is:

1. After screensaver timer and no activity, Dakboard starts.

2. After some other time, Dakboard is dimmed.

3. If dimmed and I touch the screen, bring up non-dimmed Dakboard. If screen is not dimmed, return to actiontiles.

Any chance of that: :)

If you want to add that extra layer of dimming DAKBoard then you need to submit a feature request to ... DAKBoard.

+1

Thanks for the quick reply. I found out what I was doing and got close to what I wanted. When I tell the Fire HD 8 to Stay Awake but set a sleep timer anyway, and it's plugged in to a charger. The Fire dims the screen after the set sleep time. The Fully Kiosk goes to Dakboard after a minute or so; this is part of the Fire Sleep time. This is an 8th generation Fire HD 8 with ads, but I never see them with the FK browser I have installed. ETAL So I have everything but item 3 from my list ;)

+1

I was also looking for the Screensaver settings which would step through the behaviors as you had defined them. I see that you are still looking to get #3 in your wish list. 


I don't understand why in the Screensaver (PLUS) settings, you can't enter the Wallpaper URL into the Playlist. (fully://color#00000)

I would like to make a playlist where I enter my DakBoard screen, let that stay at the same brightness as the currently running Start URL(AT, in this case), and run for 5 minutes, then move to the next item in the playlist, the Wallpaper URL code for black. Ideally, this part of the playlist also allows changes to both duration and screensaver brightness. 

I don't really want to have to setup Motion Detection. Mostly because I don't need it. If I want to get to AT, then it's just a simple tap to wake the screen. But also, because if I did want to have the device sense when I walked past it, I'd rather it just brighten the screen and show me my Dakboard screen, rather than exiting the screensaver. 

Turns out after updating to Fire OS 6.3.0.1 I can't dim Dakboard at all :(

+1

I spent about 1-2 months basically fighting with the locked down nature of FireOS and the parts of Fully/ActionTiles that wouldn't do what I wanted before I gave up, returned my FireHD 8, and bought a $64 Walmart Onn 8" Android tablet. It comes standard with Android 9 Pie. 

https://www.walmart.com/ip/Onn-Android-Tablet-8/767511102

In less than 2 hours with the new device, I had set it up exactly as I had wanted in my previous post. Given that this tablet is running stock Android and isn't feature limited by the FireOS port of Android, I can't quite understand why so many people recommend the Fire HD tablets. None of the sideloading APKs to get Google Play, no forcing Nova Launcher, none of the features in Fully that wouldn't work. 

Now the only thing I have to sort out is getting a on-wall mount made for this tablet. The fine people at MakesbyMike offer a custom 3D printed CAD design service for $15. Just need to get them to create this design specific for this tablet, and I'm set. 

PINNED

Just figured out how to get what I wanted in terms of screensaver and dimming. Posting in case anyone else is following along.

Turns out there is some non-intuitive behavior and coupling between Fully and FireOS. Here is what i wanted:

1. After Fully screensaver timer expires, start Dakboard at full brightness.

2. After a certain amount of time, dim the Dakboard screen but keep it "slightly" visible - not a black screen.

3. Return to actiontiles on touch.

The dimming of Dakboard was the issue. Here is how I solved it:

1. In FireOS, Developer Options -> Stay Awake : Turn this ON.

2. In FireOS, Display -> Advanced -> Sleep : Select the TOTAL amount of time from inactivity to dimming.

3. In Fully, Screensaver (PLUS) -> Screensaver Timer : Set to seconds of inactivity to Dakboard starting. Should be less than time set in step 2.

4. In Fully, Screensaver (PLUS) -> Screensaver Wallpaper URL : Set to your personal Dakboard screen URL.

5. In Fully, Device Management -> Keep Screen On : Turn this OFF. This was the non-intuitive part for me.

Now, after the time in step 3 Dakboard starts, and at the time set in step 2 the display dims.  By the way - the display will dim whether you are in the screensaver or not after the sleep timer in FireOS expires.

Joe, is this still working for you?  My Kindle is set up the exact same way and dims when the sleep timer activates in FireOS.

Here's my problem, motion detection is not waking the Kindle from sleep mode so the screen just stays on my screensaver in a dimmed state.  I've tried everything.  

Also, I have my motion detection set to wake the screen, but stay on screensaver since I'm using Dakboard as my screensaver.  I want to be able to walk up and have the brightness return, yet stay on my Dakboard so I can look at the schedule.   Then I can get to AT by touching the screen.  

Any tips to fix the motion detection?

John Metcalf,

Nothing can wake a Fire HD Tablet from "sleep mode"; including Fully motion detection or screen tap

You must enable Android OS developer options, and "Stay Awake when powered". And never use sleep or the power button.

Hi Terry, thank you for replying!


I do have "Stay Awake when powered" on.  Everything stays on, yet it dims the screen at the time set in the "sleep after xx minutes" in the device display settings.  

Motion detection will not pull it out of that dimmed mode.  

I want it to dim, yet I want it to brighten on motion detection.  I cant use the fully dim URL because I'm using Dakboard for the screensaver and that command doesn't work in a URL Playlist. 

If you're using "sleep after xx minutes" then you are putting it to sleep instead of just activating the screensaver URL. Do not use any "sleep" related settings.