0
On Hold: Discussion Open

Secondary "distress" PIN or other Panic Buttons

Derrick Ho 3 years ago in Security updated by Al Rosen 2 months ago 9

I have ActionTiles with a panic button that will set off the alarm manually.  

I would like this to be easy to turn on, but harder to turn off.

I would like this panic button to have no PIN requirement when turning on, but require a pin to turn off.


A scenario plays in my mind...


A bad guy enters the house and I am in it... so I press the panic button in hopes to scare the bad guy off....


but the bad guy sees my ActionTiles -- and I have several of them throughout my house always on so that I can monitor my house from anywhere without having to wake up my devices -- He sees the panic button and presses it and the siren turns off.  Now he can rob me in peace!


This is why I ask for such a feature so that I can set off the alarm easily, but when the bad guy tries to turn it off he will see a PIN screen... he will try to enter something, but will give up.


What are your thoughts on this?


(p.s. I have a Samsung Smart things hub.  I know that I could use a routine to get allow turning on the siren but no way to turn it off.  However, routines don't have the ability to customize the color to Red, nor do they have the ability to show an with an interactive style.  Tapping a routine doesn't change it visually, but a button does and I would like that.) 

Use webcore, virtual switches.  First switch starts siren via webcore. Turning that switch off won't do anything.  A second switch could be protected with action tiles pin, it will turn off siren. 

Can you please provide some insight in the use of webcore, virtual switch that will first fire the the siren?

Yep, the easiest solution is probably creating a second button to stop the siren, and PIN protect that button.

This is my workaround using only ActionTiles and Smartthings 


I have two tiles 1 for the alarm and a second one to change my Smart Home Monitor state.


The alarm tile is not a routine, it is a virtual light bulb.  That way The tile will obey the on/off styling.  I have a routine that observes when the light turns on.  When it turns on it triggers the alarm on.  Then I create another routine that observes the SHM state. When it becomes disarmed it will turn the alarm off.


The alarm tile has no pin.  Changing the SHM status requires pin.

I am trying to make a panic button "tile" .Can anyone be more specific with making the tiles , especially  when the light bulb turns on ( ? virtual light bulb ) how this triggers the alarm.. I can't seem to get this to work with AT and SHM

thanks,

Al

If you aren't using webcore and want to do this in SmartThings app only... I think you could use this Simulated Alexa Switch switch type.  If I remember correctly this is a virtual switch that is also a contact sensor, so when you turn on this panic button switch, it also opens(or closes?) the contact sensor in this device.

To use this, you would have to add the Device Handler at the top of the link into your SmartThings IDE

Then go into your Device in the IDE , find your Panic button switch, edit it, change the Type to "Simulated Alexa Switch"

Now go into the SmartThings app, SHM, configure(gear at top), Security, open/closed sensor, then add your panic button for Armed/Stay.

You should test this in the SmartThings app, SHM to Armed/Stay, go to your Panic button, turn it on and it should trigger your SHM alarm.

NOTE-if you want the Panic Button to always work  (regardless of SHM armed), I think you would need to use webcore, or possibly with SmartThings routines.

Kevin;


Got the test you mentioned above to work. Need to create 2 routines ,. First to set armed /stay  and change to panic mode ( did this ). 2nd routine  to monitor for change to armed /stay and only panic mode ( did this part ) but can't figure out how to turn on Simulated alexa switch after a slight delay so there is time for they system to be armed .

Thanks,

Al

It now works. The problem is that for the SHM delay module there was a modefix section that I had to allow panic mode to be enabled for the appropriate alarm state.


Thanks,


Al