0
Fixed

Smoke and CO Tiles show "Tested" as status

bmac6966 11 months ago in Panels (dashboards) • updated by Terry (ActionTiles) (Co-Founder) 5 months ago 23

Hi. 


I have 3 smoke alarm / CO detectors. Two correctly shows the status as clear. The third one shows the CO status as "tested". 


SmartThings, it shows the status correctly. 


I've tried retesting the alarm to clear the status, remove and reads the tile,  but no luck.  Any thoughts?

Answer

Answer
Fixed

Fixed in Release v6.8.0+027 today. Please contact Support@ActionTiles.com with related questions.

Waiting for Customer

Mine was stuck on "Tested" for a long time too... I think all it took was re-testing it to force SmartThings to update. - Remember... we can only get the values that SmartThings relays to ActionTiles.


So to diagnose this; please use the SmartThings IDE first, to check what values are set for the Current States of the Attributes:


Login to your SmartThings IDE API webpage, check under "My Devices", open the detail page for the Thing, and check this section, "Current States:



If it's a Water / Moisture sensor, we recommend trying to give it a little manual initialization by wetting across the contacts with your finger or a damp cloth. That will usually force an initial value to be sent to ActionTiles. This may be applicable to other Sensors too, such as Smoke & Carbon Monoxide Detectors.

You are correct.  In the status page of the detector, it shows "carbonMonoxide: tested"

The problem is the sensor are in a casing and i'm pretty sure if I open it, if there is a way, that i would break something.. Any other thoughts?

Ideas... not suggestions 😉...


  1. Try the Smoke testing mode (hmmm... Is there a separate button press method to test "Smoke" rather than "CO"?
  2. Try wafting a bit of real (or canned) smoke past the detector in order to force it into "Smoke Detected" state (which should be followed by "Clear" automatically).
  3. Similar to #2, I think there is a special canned "CO" product designed to test Carbon Monoxide detectors.
  4. Contact Support@SmartThings.com (and http://community.smartthings.com) ... technically, this is a bug; though I don't know if it is the fault of the First Alert (manufacturer) or SmartThings missing or misinterpreting a Z-Wave message. If this is a "Works With SmartThings" product, they should be able to escalate.
  5. Use a custom DTH, in which the code manually resets to cleared. Not recommended, since this would make it non-local execution.
  6. Accept that "Tested" is equivalent to "Cleared" as far as real-world functionality is concerned (see #3 to prove it). We could then consider a Feature Request to decide what the Intention is of the "Tested" state... i.e., what the proper Tile appearance is.

These are the First Alert Zcombo..

The other two that i have do show clear.

Trying changing to another DTH and back and status is the same.. I'm going to try to remove it and re add to see if that helps any.




Well just an update.. I ran the test on the other two I do have and now carbonMonoxide: tested.  


Bug?

I have doubts as to what the actual "spec" behavior should be.

  • "tested" is accurate ... i.e., the last action taken by the Thing is it was successfully tested.
  • "clear" can only occur if the First Alert actually sends a "clear" message back to SmartThings. When should it do that? After pressing the button to stop the test? After a certain number of minutes?
  • All I know is that I had mine stuck on "tested" for the longest time, then just ran a few more tests, and it went to "clear".
    • Possibly the "clear" Z-Wave message isn't making it through to SmartThings and/or the SmartThings DTH isn't grabbing it reliably and/or the SmartThings platform is "iffy".
    • Watch Live Logging while running tests. https://account.SmartThings.com

I have been running the test off and on for an hour.. The only thing that changes is the battery estimation. but everthing is clear except carbonmonxide. 

Here's a snippet of live logging.  it doesn't show anything else except these lines when it's done completing it's test.

4:41:06 PM
debug 'zw device: 10, command: 8003, payload: 5E ' parsed to [['name':'battery', 'unit':'%', 'isStateChange':true, 'value':94, 'displayed':true, 'linkText':'First Alert Smoke Detector and Carbon Monoxide Alarm (ZCOMBO)', 'descriptionText':First Alert Smoke Detector and Carbon Monoxide Alarm (ZCOMBO) battery is 94%]]
 4:38:54 PMdebug 'zw device: 10, command: 8003, payload: 5F ' parsed to [['name':'battery', 'unit':'%', 'isStateChange':true, 'value':95, 'displayed':true, 'linkText':'First Alert Smoke Detector and Carbon Monoxide Alarm (ZCOMBO)', 'descriptionText':First Alert Smoke Detector and Carbon Monoxide Alarm (ZCOMBO) battery is 95%]]

On Hold: Discussion Open

Curious what SmartThings App says... Because if it is ignoring the "tested" value, then it is difficult to escalate this to SmartThings Support.


The SmartThings DTH may be in the public GitHub, if a fix is possible. It's impossible to say without a lot of DTH low level testing if the problem is SmartThings or First Alert.

Using the official DTH, in smartthings it says it's cleared, but it only shows the status of one.  Not sure if it's one status/icon either the smoke or the co2 and/or both. 


In actiontiles, you can see both but you don't get that granularity in the smartthings dth.



+1

On the bright side, at least it's consistent and it shows "tested" on all three now.. so when i roll this out to the wife, she can't question why the results of the three detectors are inconsistent. lol

I spoke with SmartThings and they feel the issue is with the First Alert ZCombo not sending the Clear for CO.  They said they have no workaround since they can only report what the Smoke/CO Alarm sends to them - that this alarm does not accept incoming data, so no reset is available.  Running the test again sometimes clears the CO Tested status (as noted above in the comments).  Unfortunately, we seem to have 2 types of First Alert ZCombo units, some reliably reset to Clear if tested again, the others however keep the CO as Tested.  Both types are ZCombo's, likely a different generation.  


So... doesn't appear that there is much we can do in the DTH unless we ignore the "Tested" and report it as Clear instead of the actual reported state.  That's not really a good idea, as Tested is useful and accurate information (also as noted above in the comments).  The likelihood of First Alert making an update to existing units is about as close to zero as possible.  So, SmartThings and First Alert are out...


That leaves ActionTiles to shim in a workaround.  Is it possible to modify ActionTiles to treat Clear and Tested statuses both as Normal (in ActionTiles tile speak; Info, Normal, Accent and Warn)?  That way, no 'Accent' would be triggered making it look like something is wrong.  Anything else could be a Warning like it appears to be now.  I know the issue is not ActionTiles, but I think this is were we could address the issue.  Thoughts?

Thanks for the research, Jason!


Having multiple States represented by the same Tile appearance is a reasonable idea, but I'm ambivalent.


We prefer that the Device Type Handler issues the most meaningful State to us so we can react accordingly, and so I'm still curious about that possibility. We want to be in sync with SmartThings's data and Capability specifications as much as possible.

To be consistent with Smartthings, a ZCombo with a Clear or Tested status shows as "clear" the detector's status, and "everything ok" in the home monitor.  


In keeping behavior consistent between ActionTiles and Smartthings, I vote for accepting Clear & Tested as good, not flagging Tested as an alert, so that a real alert like a smoke or CO alarm is clearly shown.  This behavior is consistent with Smartthings' handling.  

+1

Just found this thread after installing two new (manufacture date Jan 2018) First Alert ZCombo units and running into the same issue.

Before I drive the family nuts testing this what are the chances that yanking the batteries and putting them back in might clear the CO?  Hasa anyonre done this?


If that can clear it, as much as it bugs me, I can see doing that after periodic testing.

Removing and reinserting the batteries is worth a try. I don't recall doing any special steps to reset my status out of "testing" ... but if I did anything, then, that's what I would have done.

+1

Tried that, didn't do anything for me.  The smoke detectors aren't on the network all the time, they go to sleep essentially, wake up when an event happens (like smoke) or a periodic heartbeat and battery level indication. Between those events, nothing.  So when I had my batteries out, the hub was likely unaware, so never updated the status - and "Testing" remains.  Perhaps leaving the batteries out for longer might help, I've done it for 15 minutes with no help.  Maybe try an hour, or 2, haven't tried that yet.

+1

Same proved to be true here.  The CO tile still shows as Tested.  I read on another website that one user found the only way to clear the status was to eclude, remove and re add the sensors.  That;s too much grief if you're going to be testing them periodically as you're supposed to.

I can't find where I read it but I thoguht I also read that the missing CO clear alarm was only an issue with the test function and not the actual detection alarm.  If that's so I guess one could but the can's of test materail and do the bag and spray test periodically.  The only drawback there is you'd actually be eating into the serviceable life of the sensors each time you did that.

I figure I'll join the chorus, hopefully there is one, of people calling or writing to FirstAlert about this issue to see if that gets me anywhere.

Thanks All for the quick replies!

Tom G.

+2
Fix Planned

We accept the suggestion to treat "Tested" status the same as "Cleared". We will use the same icon for both statuses.

Hello, Has this suggestion been implemented yet as my smoke detectors are still lit up after testing them. It would be really nice to get this fixed.

+1

It certainly will be nice to have this fixed; but there's no need to ask. Just "Follow" this Topic, please.


The Status of this Topic will be changed as progress is made. The Status will read "Fixed" after it is implemented and deployed. We do not give out ETAs so as not to make broken promises.

Answer
Fixed

Fixed in Release v6.8.0+027 today. Please contact Support@ActionTiles.com with related questions.

Commenting disabled