Waiting for Customer

Location Mode Tile Displaying Incorrect Mode

xdreamwalker 7 years ago in Panels (dashboards) updated by Alex (ActionTiles) (Co-Founder) 2 years ago 13

I have noticed that my Mode tile does not always show the correct mode. It seems to happen when SmartThings has switched from Away to Home.

A screenshot shows that AT shows Away, but ST shows Home.

Image 1485

I have tried to change the mode using the AT tile, the tile will show home, but after a refresh of the page it shows Away again. The ST IDE Log shows this after I try to change the mode to home via the AT tile.

Image 1486


Hmmm... I'll see if we can reproduce this error.

If anyone else is experiencing it; please chime in, thanks!!!

I think its a Smartthings issue, not ActionTiles. I noticed this about 6 months ago and I created a core piston as a workaround to set the mode based on SHM.

Well this hasn't been happening lately. I'm not sure what changed, if anything.

My SmartThings phone app (classic), webcore, and IDE show one location mode and my ActionTiles displays all how another. This occurs when I use a webcore piston to change the $smh $locationmode variable. This appears to be a delay of several minutes. 

Waiting for Customer

1. What is the "$smh" variable??

2..Please note that SmartThings's "location.mode" (shown in the OP's screenshot and in ActionTiles's Mode Tile) is entirely distinct from the Smart Home Monitor SmartApp's "Armed Mode" (shown on the SmartThings Classic App dashboard solutions page and the ActionTiles Smart Home Monitor Tile).


The $locationmode (forgive the error) variable in webcore is the Location mode. 

Well... is SmartThings failing to relay Mode changes to ActionTiles from time to time?

Please try some or all of these:

  • While changing the Location Mode in various ways, please observe the Live Logging tab in https://account.SmartThings.com ; For example, carefully compare what happens when changing Location Mode via the SmartThings Classic App vs via WebCoRE. Changes should be logged and should be reflected immediately in ActionTiles, regardless of the method used, unless one method is not functioning properly on the SmartThings side. ActionTiles just "subscribes" to changes to the Location object.
  • Try updating your ActionTiles Connector by Authorizing or De-Authorizing a Thing (under My Locations / location / AUTHORIZE.
  • Try uninstalling the "ActionTiles V6 (Connect)" SmartApp using SmartThings Classic App / Automation / SmartApps. Then re-add the Location (which re-installs the SmartApp) via ActionTiles / My Locations / (+).



Having this issue as of late, appears to be related to the move from "Classic" to "...whatever the new one is called"

- Changing modes directly in ActionTiles will show the correct mode

- Changing modes via the ST app (new not classic) will not reflect the mode change in ActionTiles

I seem to have temporarily resolved the problem by hitting the 'power' toggle for the ActionTiles app from the SmartApps screen in the new ST app.  This loaded for a second then brought me to the configuration screen for ActionTiles (where one can select devices and such).  At that point I hit "done" which took me back to the SmartApps screen (power toggle still 'on').  From here, ActionTiles is now displaying the correct location mode.

Looking at the LiveLog for each (pre / post fix), the 'locationEventHandler' and 'sending data to AT' are simply not present pre fix

12:37:07 PM: debug sending data to AT
12:37:07 PM: debug locationEventHandler [name:mode, deviceId:null, isoDate:2020-10-25T17:37:07.371Z, unit:null, value:Night]

Please open a private ticket and include you account information. There are a few things we could try to resolve this.

I know this is an old thread, but I thought I'd see if anyone else is having this issue still? My issue seems to be exactly the same as the original post, except it is when my mode switches from Home to Away, and instead of showing the previous mode, it shows Night. It isn't consistent and only seems to be maybe once a week.

Ongoing issue that seems to have only gotten worse over time.  In my environment it has expanded to "generally ActionTiles is only up to date with any given thing (mode, device state, etc) about 75% of the time".  I've tried the trick where you remove all the devices and add them back to the AT smart app...it does the job but only temporarily.  I don't blame the AT team (much), it appears to be a ST issue that's getting less and less stable.  It got so bad I abandoned the use of mode all together and redid all of my WebCORE rules so that I could re insert some reliability 


Please open a private ticket and include the details of your account and location.

The issue with Location Modes reoccurs periodically on the SmartThings platform and then corrects itself without any intervention. This affects all apps, not just ActionTiles. Please check again in a day or so. If the issue remains, please open a private ticket.