0

Broken image media tiles in Android

Jean 12 months ago in Browsers Tablets Phones / Android updated by John Johnston 3 months ago 13

Referring to following topic though my post is only applicable to Android Chrome and Fully Kiosk browsers (both using android system webview version 111.0.5563.58) https://support.actiontiles.com/communities/12/topics/9592-images-on-media-tiles-are-not-loading-on-google-chrome-browser

It seems this problem started happening after the last android update (Samsung Tab A).


It seems http media tiles are no longer accepted in actiontiles. The (local network) http URLs display correctly if requested directly from the browsers, but seems to fail (broken link) when using actiontiles.

Is there a workaround for this? My ipcams unfortunately don't provide https interface :(. 

The "Mixed Content Mode" switch in Fully Kiosk doesn't seem to help (this was also the recommendation from the Fully Support.

Any ideas welcome, I'd prefer to avoid having to set up an https reverse proxy.

Android

Thanks for getting back. I looked for AT app but didn't find it in the play store. That wouldn't truly solve my problem though as i use fully with motion activated screen. 

I found the solution for fully kiosk browser which is system WebView based. The auto-update for Android system WebView was the problem as version 1111 doesn't allow for mixed content. The solution is uninstall the update, that reverts to an old version that usually works. It's possible to install a 110 version from an APK that you can find on uptodown for example. 

This worked for me - just remember to disable the auto-update for system WebView in play store to avoid having to start over 🙄. 

Regards

thanks for the info.  I see that I am at Webview 111.  The Samsung Tab A that I use is the only Andoid device I have.  How do I roll back to the prior version of Webview?

uninstall system WebView in the play store. That will revert to an old version. If you want you can update to more recent version by downloading a 110 APK from uptodown for example. 

+1

that worked ... thanks!

and idea the fix for A Fire Tablet?  I am seeing the exact same thing but can’t fix it!

did you find a solution for this? 

Not sure about Fire. Did you check other posts? I know there are Fire specific ones.

+1

looks like this just happened again. It’s on default system web view - Samsung had a big update and now fully will not render the local http stream. 
if you go to it directly from browser it does load

Any known solutions to this? 

I had to upgrade my Note 20 ultra to a S23 ultra and suddenly I'm have some live media (radar etc)  not rendering on the Action Tiles App on the phone. The media tile flashes a moment and then poof, gone. 

Works fine on a Pale Moon browser on a PC

Oddly,  on Android using Chrome,  if I use the mobile site I also do not get the media tiles.  BUT if I ask for the desktop site,  I get them back functioning.   

I ended up fixing by switching from local IP address to using DDNS. Even though that’s http instead of https - that ended up working