0
Fixed

Arlo Cameras as Switch and Motion Sensors missing from Authorize Things

benbarham 2 years ago in Things & Capabilities • updated by Terry (ActionTiles) (Co-Founder) 2 years ago 13

Just been setting up my first Panel to replicate / replace a Smarttiles dashboard I have running. Very pleased with the new features and well worth the licence fee. The only 'things' I have been unable to add relate to my Arlo cameras. I have had the motion detector element of one of my cameras as a tile and also a switch to switch on/off the camera. They are not listed as an option to authorise though they are officially supported by Smartthings. Not a big deal - just wondering if I have missed something?

Answers

PINNED

Thanks Terry!


Had a quick test and can successfully add the cameras. Correctly reports Battery Level and Status and am able to turn the Cameras ON/OFF via the Tiles.


Thanks again! :-) 

+1
PINNED

Hi Terry, yes all working as expected. Thanks for your help.

Researching

I'm assuming this KB/FAQ is the issue with the Arlo Camera as a "Switch" / "Motion Sensor", we need it to claim both Capability Switch, Motion Sensor, and Sensor, and Actuator.


We will try to confirm this...




But... Please let me know if you are using a custom Device Type Handler

Thanks Terry. Not using a custom DTH. Just installed with the Arlo (Connect) app provided by Smartthings. I realise I'll never be able to view the feed but being able to 'arm/disarm' the cameras along with viewing motion detection within Actiontiles, particularly for my garden cam, is useful but not essential.

+1

I had the same issue with my Arlo Cams not showing so I created a Simulated Switch for the camera power On/Off and a Simulated Motion Sensor for camera motion active/inactive and added them to ActionTiles. Then using CoRE I created 3 pistons.

Piston 1

If Simulated Power switch changes to On then turn On Camera, but if changes to Off turn off Camera.


Piston 2 (to keep ActionTiles in sync if you turn camera on from SmartThings App or Arlo App)

If Camera changes to ON then using simulated power switch Turn On but if Camera changes to Off then using simulated power switch Turn Off.


Piston 3 (Motion)

If Camera motion changes to active then using simulated motion sensor show active but if Camera motion changes to inactive then using simulated motion sensor show inactive

(NB Until Motion is triggered once the Motion tile just shows a ? but once triggered the standard motion icons are shown.


Works well so far although motion has a bit of a lag updating the tile but that seems to be Arlo to SmartThings delay.

That's a good idea. I have a few simulated switches for other uses and use Core so shouldn't take long to get this setup.


I am still hoping ST will make the necessary changes required to get this working as it used to with Smarttiles but in the mean time this is a good solution - thanks. Now just need to find a way to stop the neighbours cat jumping in front of the garden camera everynight...

Thanks for having me onboard! :-)


It would be great to see these added, assume the DH needs to be changed at their end right?


On a similar note, out of curiosity, how is it am able to add them to SmartTools and Stringify as switches yet not to ActionTIles? Apologies if this is an obvious answer.

Hi Terry,


I did see that earlier but we cannot edit the delivered DH, does someone need to put a request in or has that been done already?


It also does not exist under templates so cannot create a custom one, I have been out the game for a little so perhaps I a forgetting something?


Thanks.

+1

We are collaborating with SmartThings to correct this on behalf of our mutual Customers.

+1
PINNED

Hi Terry, yes all working as expected. Thanks for your help.

PINNED

Thanks Terry!


Had a quick test and can successfully add the cameras. Correctly reports Battery Level and Status and am able to turn the Cameras ON/OFF via the Tiles.


Thanks again! :-) 

Commenting disabled